S32 studio make error

cancel
Showing results for 
Search instead for 
Did you mean: 

S32 studio make error

Jump to solution
420 Views
Contributor III

Hi, expert:

I used S32 studio  to build mcal files(MCU type: MPC5744).

When I executed the "build" command. There are many errors in "problem" window. 

pastedImage_4.png

1. ccN1mZga.s files is not existed.

2. "Temp" folder is not source path, so the compiler shouldn't compile this folder.

so , how can I solve this problem? Thanks.

Tags (3)
1 Solution
19 Views
NXP Employee
NXP Employee

You see S files in temp folder because they are generated on intermediate step during compilation of your C files.

You can add --save-temps option

save-temps.PNG

and see all of them in your build folder.

After that you will find out following:

spi_dspi_irq.png

Finally you will see invalid inline assembler syntax in EXIT_INTERRUPT().

View solution in original post

5 Replies
20 Views
NXP Employee
NXP Employee

You see S files in temp folder because they are generated on intermediate step during compilation of your C files.

You can add --save-temps option

save-temps.PNG

and see all of them in your build folder.

After that you will find out following:

spi_dspi_irq.png

Finally you will see invalid inline assembler syntax in EXIT_INTERRUPT().

View solution in original post

19 Views
Contributor III

Hi, Jiri:

I found the root cause. In compiler parameter, I didn't define "USE_SW_VECTOR_MODE" macro. So the compiler pop up error.

But I still have one question: If I didn't define the macro, why the temporary files are added to the build process?

Those temporary files(displayed in the problem window) are not found in local computer. And the temporary file names are not the same in each build process. Thanks.

Bryce

0 Kudos
19 Views
NXP Employee
NXP Employee

Hi Bryce, 

I'm not familiar with this piece of SW - but from attached PDF I can see that the (table 3-4 in attached PDF) USE_SW_VECTOR_MODE flag (or define) is mandatory when you are not using OS. I'm assuming that with HW vector mode are generated different files which are related to OS. But I'm only guessing.

Jiri

0 Kudos
19 Views
NXP Employee
NXP Employee

Hi, 

it is possible that your errors are related to this known issue. Can you get .elf file after build? Are errors shown also in build console? 

You can try the workaround mentioned in link above - it is working in some cases. If you are using S32DS for PPC v1.1 - try to update to version 1.2 

Jiri

0 Kudos
19 Views
Contributor III

Hi, Jiri:

As your advise, I try the the following methods:

1. Follow the instructions to change the configuration of S32 studio(you mention in the known issue.).

2. Download the  Version1.2, use the latest tools.

3. I write makefile and call the S32 compiler and linker.

The error still pop up. 

In the problem window, the information is shown below:

pastedImage_1.png

In the console window, the information is like:

pastedImage_2.png

I add the source code and manual of compile parameters in the attachment. Could you compile those code in your environment? Help me to figure out the problem.Thanks.

Bryce 

0 Kudos