S32 Design Studio so slow it is unusable on some machines

cancel
Showing results for 
Search instead for 
Did you mean: 

S32 Design Studio so slow it is unusable on some machines

Jump to solution
236 Views
Contributor II

I have just purchased the development board for the MPC5748G, and installed S32 Design Studio for Power Architecture 2017.R1.

On some machines, Eclipse is so slow it is unusable.  

We currently use other MPC devices using CodeWarrior Classic, and Eclipse V10.5 with no issues.  For comparison, MPC5604B example on Eclipse V10.5 cleans and builds in around 30seconds on all machines tried.

With Eclipse S32 DS, it takes around 18mins to clean, and 30mins to build the example project Hello on one machine, and around 1min on a second identical machine with the same version of Windows.  Connection to the network does not affect the result.

What dependencies do we need to check to get DS running consistently?

Labels (1)
1 Solution
61 Views
Contributor II

Found the problem.

Removing Trusteer Rapport makes DS work the way it should (2.9Sec to clean and build a basic demo instead of 18 minutes).

Interestingly, Trusteer had no slow down effect on Eclipse CDT, or the build of Eclipse for MCP56xx, but really killed the machine when S32 DS was run.

View solution in original post

5 Replies
62 Views
Contributor II

Found the problem.

Removing Trusteer Rapport makes DS work the way it should (2.9Sec to clean and build a basic demo instead of 18 minutes).

Interestingly, Trusteer had no slow down effect on Eclipse CDT, or the build of Eclipse for MCP56xx, but really killed the machine when S32 DS was run.

View solution in original post

61 Views
NXP Employee
NXP Employee

Hi, 

did you check Windows task manager during build process? S32 DS is slower than CW because it is more complex. But there must be something wrong with this particular PC machine if the difference is in tenths of minutes. 

Jiri

0 Kudos
61 Views
Contributor II

I was mistaken.  Both machines are unusable.  They both initially compile very quickly then dramatically slow down after a few seconds.  One machine just gets slightly further before it slows down. 

As they are just running a make file, I would expect there should be no extra complexity from using DS rather than CW.  The command being run is make -j4 all for the clean which just runs an rm command to delete files.

I would guess the slow down is associated with a license check, or something else not directly related to compilation.

0 Kudos
61 Views
NXP Employee
NXP Employee

Hi, 

there is different compiler in S32DS. But such big slow down is strange. As far as I know, there is no licence check when compiling is started. Even pretty complex projects are compiled in couple minutes. 

What about the Task Manager? 

Jiri 

0 Kudos
61 Views
Contributor II

Hi,

On task manager:

Memory Used: 20% for Everything

Network Activity: approx 0%

CPU Load: < 6% for everything

WmiPrvSv.exe is the task most using the CPU at around 2%

DS is second most active at 0.5%

After exiting the PC is unusable until rebooted (IE, Firefox, Windows Explorer do not open any windows when trying to start them).

Running make -j4 clean from the command line is fine (< 1sec), provided that DS is not started since powering on the PC.

Running DS, exiting, and then running make from the command line, is very slow (> 15mins)

Uninstalling DS, rebooting and reinstalling DS has no effect.

Removing Visual Studio has no effect.

Any ideas appreciated.

Dermot

0 Kudos