Issue with the usage of Standalone tag in the ProjectStaticFilesGenerationMode

cancel
Showing results for 
Search instead for 
Did you mean: 

Issue with the usage of Standalone tag in the ProjectStaticFilesGenerationMode

166 Views
Contributor III

Hello ,

I have changed the tag in the processorExpert.pe from <ProjectStaticFilesGenerationMode>Linked</ProjectStaticFilesGenerationMode> to <ProjectStaticFilesGenerationMode>STANDALONE</ProjectStaticFilesGenerationMode> and I see the below related to the missing inclusion of the header files during the build as can be seen in the second snapshot.

So could you please let know how should i incorporate the changed path in the make.

pastedImage_2.pngpastedImage_3.png

Thanks and best regards!!!

0 Kudos
4 Replies

3 Views
NXP Employee
NXP Employee

Hello,

could you please write me, which version of S32DS you use and which example did you try to switch?

Have you also seen the tutorial below:

https://community.nxp.com/docs/DOC-342838 

Regards,

Martin

0 Kudos

3 Views
Contributor III

Hello ,

I made the changes as mentioned above , but I still have the issue as the below files are not getting included during the compilation.

pastedImage_2.png

0 Kudos

3 Views
Contributor III

Hello ,

Sorry i Missed out to mention the version number , I make use of the version 2.0

pastedImage_2.png

0 Kudos

3 Views
NXP Employee
NXP Employee

Hello,

I wanted to ask you about project, but I saw you created new thread and my colleague Jiri Kral posted you some answer.

https://community.nxp.com/thread/501563 

I followed the tutorial I shared above in S32DS 2.0 and it works correct on my side. You can try to clean project, generate SDK code and compile again.

Regards,

Martin