How do I choose the the lastest SDK for S32K312

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

How do I choose the the lastest SDK for S32K312

Jump to solution
742 Views
jetty1012
Contributor II

Hello all, I'm new here and it's my first time to use this product so I've got some questions.

At first, I downloaded this SDK for S32K312

SW32K3_RTD_4.4_R21-11_3.0.0_CD04_D2212_updatesite.zip

But after I installed it, I could not select any SDK when I was trying to build a new project. It didn't report any error during the installation. So I asked my colleague to try it and he got the same problem.

Then I just tried to download and install an older version which is SW32K3_RTD_4.4_1.0.0_DS_updatesite_D2110.zip

It seems that this can work but I wonder why the newer version didn't work.

jetty1012_0-1681367828725.png

How do I choose the the lastest SDK for S32K312?

Thanks.

Jetty

0 Kudos
1 Solution
699 Views
jiri_kral
NXP Employee
NXP Employee

Hi, 

S32DS v3.5 doesn't fully supports full S32K3xx device family. S32K312 is fully supported in S32DS v3.4: 

jiri_kral_0-1681478571144.png

 

 

 

 

View solution in original post

0 Kudos
3 Replies
721 Views
VaneB
NXP TechSupport
NXP TechSupport

Hi @jetty1012 

From the provided information I infer that you are using S32DS v3.4, am I correct? If I a, the SW32K3_RTD_4.4_R21-11_3.0.0_CD04_D2212_updatesite.zip is provided as an update site for S32DS v3.5, so it is not possible to access it via an older version of the IDE.

Another possibility is that the software was not correctly installed to check that this is not the case you must see the package in the Installation Details.

0 Kudos
710 Views
jetty1012
Contributor II

Hi @VaneB , thanks for your reply.

I'm using S32DS v3.5 so probably it's not because of the version of the IDE.

jetty1012_1-1681438820949.png

I checked the Installation Details, and I found both RTD v1.0.0 and v3.0.0 from the Installed Software.

Does it mean I've already installed the software successfully? If so, it just puzzles me that I cannot choose SDK v3.0.0 when I'm trying to create a new project.

jetty1012_0-1681440209326.png

Thanks,

Jetty

 

 

Tags (1)
0 Kudos
700 Views
jiri_kral
NXP Employee
NXP Employee

Hi, 

S32DS v3.5 doesn't fully supports full S32K3xx device family. S32K312 is fully supported in S32DS v3.4: 

jiri_kral_0-1681478571144.png

 

 

 

 

0 Kudos