GHS plug-in can NOT successfully installed in S32DS for Power Architecture version 2017.R1

cancel
Showing results for 
Search instead for 
Did you mean: 

GHS plug-in can NOT successfully installed in S32DS for Power Architecture version 2017.R1

973 Views
Contributor II

Dear Engineer:

I update  S32 Design Studio for Power Architecture from version v1.2 to version 2017.R1.I found a issue ,when I integrated the GHS compiler toolchain in S32DS there was an error .

1.bmp

Details:

Cannot complete the install because one or more required items could not be found.
Software being installed: Green Hills MULTI for Eclipse (PowerPC) 2.1.9 (ghs.multi.ppc.feature.group 2.1.9)

Missing requirement: MULTI Plug-in 2.1.9 (ghs.launch.multi 2.1.9) requires 'bundle org.eclipse.cdt.debug.mi.core 0.0.0' but it could not be found

Cannot satisfy dependency:
 From: Green Hills MULTI for Eclipse (PowerPC) 2.1.9 (ghs.multi.ppc.feature.group 2.1.9)
 To: ghs.launch.multi [2.1.9]

 

I uninstalled the S32DS and GHS to reinstall,the problem will still appear.

I do not have this problem When I use S32DS for Power Architecture version v1.2.

 

Best Regards!

0 Kudos
2 Replies

29 Views
NXP Employee
NXP Employee

Hello,

Unfortunately GHS Eclipse plugin does not support Eclipse v4.6 (Neon). Therefore you cannot install and use the plugin in the latest S32DS for Power 2017.R1

I'd recommend you to use S32DS for Power v1.2  for GHS support in S32DS.

Stan

0 Kudos

29 Views
Contributor III

Hi, Stan

stanish

Is this a S32DS issue which belong to NXP, or GHS plugin issue need GHS tech to fix?

I tried to install the GHS plugin from ghs multi 7.1.6 (comp_201754) into S32DS 2017.R1, it still failed.

QQ截图20180131162930.png

/WX

0 Kudos