Eternal "configuring GDB" if P&E Multilink not connected or target OFF

cancel
Showing results for 
Search instead for 
Did you mean: 

Eternal "configuring GDB" if P&E Multilink not connected or target OFF

1,045 Views
manexagirrezaba
Contributor II

Hello

 

Our team is developing on MPC5744P using the MC33908 eval board and a MPC5744P daughter board, as well as a P&E Multilink Universal cable for downloading and debugging. The IDE used is S32 for Power 1.0.

 

When pressing the "Debug" button, there are cases where the target can be forgotten to turn on, or the Multilink cable be disconnected, or in use under another program (the P&E Nexus Programmer for bare downloading).

 

In those cases (which are mere and common "mistakes") result in the debugging process getting stuck in "Configuring GDB...". Pressing the STOP button next to it shows "Cancel Request" next to that message, but the "Configuring GDB..." is never cancelled.

 

Then, the only option is to close and re-open S32. And if you dare starting another debugging session without doing that, the P&E Multilink fails to respond (it is neither detected by S32 in the "Debugger" Tab under Project Properties/Run&Debug" nor by the P&E Nexus Programmer) until the computer is rebooted.

 

- Is there any more comfortable workaround (either official or based on your experience) on this embarrassing issue (which may happen to anybody)?

 

Thank you.

Labels (1)
0 Kudos
3 Replies

266 Views
stanish
NXP Employee
NXP Employee

Hello,

Thanks for this report!

I'm able to reproduce this issue on my side. It occurs sort of randomly and I haven't found a exact reproducible instructions yet.

Anyway, we are aware of this stability issue (logged in our defect database under ENGR00372722) and we'd like to improve the stability in the next release.

I'd recommend you to "kill" the GDB process(es) directly in the task manager as a workaround. This way you don't have to restart S32DS.

S32DS_Power_kill_GDB_Multicore_Processes.png

Hope it helps,

Regards,

Stan

0 Kudos

266 Views
ronliu
Contributor IV

Hi

I couldn't find these processes in windows 10 system?

Thanks.

0 Kudos

266 Views
martin_kovar
NXP Employee
NXP Employee

Hi,

these processes run only, if you have active any debug session.

Regards,

Martin

0 Kudos