MC9S12XDT512-data on CAN_H.

cancel
Showing results for 
Search instead for 
Did you mean: 

MC9S12XDT512-data on CAN_H.

2,072 Views
candriver
Contributor I
Respected friends...
 
I am using CAN DRIVER for MC9S12XDT512 .and i want to see my data on CAN_H and CAN_L on CAN0 port...i am able to see my data on Rx and Tx buffer and memory but when i used digital CRO for checking my data i got constant voltage level on CAN_H and CAN_L(5 volt).......even i am not getting data on rx and tx pin of transciver IC.........
 
If anybody knows why it is coming like this plz help me.....
 
Thanks
Labels (1)
0 Kudos
5 Replies

233 Views
DannyM83
Contributor III
Are you using the demo9s12xdt512 board?

If the CANTX0 and CANRX0 MCU pins do not change during CAN transmision, then it is likely that you have not set up the MSCAN module correctly.
0 Kudos

233 Views
candriver
Contributor I
Hi..
 
Ya i m using demo9s12xdt512 board.......i am using same mscan module configuartion which is used in Xgate CAN driver available in AN2726......
 
i have set up in loop back mode..........in loop back mode can we see the data on CAN_H and CAN_L....????
 
Thanks....
0 Kudos

233 Views
DannyM83
Contributor III
That'll be your problem then. I doubt the signal will be output to the pins in loopback mode. Try testing the pins in normal operating mode.
0 Kudos

233 Views
DannyM83
Contributor III
Does the signal appear on the TXCAN0 and RXCAN0 pins (pins 104 and 105)? If so then the problem is transceiver related.

Ensure your jumper settings are correct and the transceiver is enabled.
0 Kudos

233 Views
candriver
Contributor I
Thanks Sir..
 
I am using 80 pin MC9S12XDT512.....and i have checked rxcan0 and txcan0 and i got 4.5v signal on these pin....which jumper i hav to check for this can u giv idea ???....becs i have already set the proper jumper....
 
and i am getting 2.5v constant signal on CAN_H nad CAN_L.....
 
Thanks...
0 Kudos