I have a problem with S12Z_AUTOSAR_OS_4_0_80_RTM_1_0_1P2

cancel
Showing results for 
Search instead for 
Did you mean: 

I have a problem with S12Z_AUTOSAR_OS_4_0_80_RTM_1_0_1P2

302 Views
Contributor I

Hello Guys,

I have installed Tresos V23.0.0 in order to use it to generate OS code sources for S12Z, I used sample project as example "Os_Sample_Sc1" provided with S12Z_AUTOSAR_OS_4_0_80_RTM_1_0_1P2

I also installed the MCAL S12ZVC_MCAL4_0_RTM_1_0_0

when I try to generate or verify code, the following issues appeared on my screen: (see enclosed screenshot)

Failed to run generator "Os_TS_T34D1M4I0R80GeneratorId" (mode: "verify") for module "Os_TS_T34D1M4I0R80"

do you have any idea about this issue ?

Thank you in advance.

Best Regards,

#

0 Kudos
7 Replies

16 Views
NXP Employee
NXP Employee

Hello Mohammed,

My colleague meet the same issue with you and after he install the "Java Runtime Environment 5.0 Update 12" in the link Java Archive Downloads - Java SE 5. It work normally.

Best regards,

Hung.

0 Kudos

16 Views
Contributor I

Hello Hung,

I still have the same problem; i add the java folder in my PATH variable environment (see the screenshot) and verified the path using CMD.after a restart, I tried to generate using tresos but I have the same issue.

it's strange ? I think there is another cause of this problem  perhaps related to  generator of TS_T34D1M4I0R80 ?!

with command when I try to run it, I have the following error 

C:\NXP\AUTOSAR\S12Z_AUTOSAR_OS_4_0_80_RTM_1_0_1P2\ssc\bin\generator>sg
Fatal error: Java Runtime Environment 5.0 Update 12 not found

and from the same directory, I can access to Java:

C:\NXP\AUTOSAR\S12Z_AUTOSAR_OS_4_0_80_RTM_1_0_1P2\ssc\bin\generator>java -version
java version "1.8.0_221"
Java(TM) SE Runtime Environment (build 1.8.0_221-b11)
Java HotSpot(TM) Client VM (build 25.221-b11, mixed mode)

BR,

#

0 Kudos

16 Views
Contributor I

Hello Hunk,

Thanks for you support. yes, I can

Find enclosed file in attachement.

BR,

#

0 Kudos

16 Views
NXP Employee
NXP Employee

Hello Mohammed,

Could you please try to add the "C:\Program Files\Java\jre1.8.0_221" in your PATH variable environment. Cause I have tried:

- Remove the "C:\Program Files\Java\jre1.8.0_221" in my PATH (please see Error.png) and I see that I meet the same issue with you (log.txt)

- After adding the "C:\Program Files\Java\jre1.8.0_221" in my PATH (please see normal.png), the issue is gone.

Note: In my computer I just have  JAVA_HOME but not JAVA.

Thank and best regards,

Hung.

0 Kudos

16 Views
Contributor I

Hello Hung,

I don't think that the leading cause is the PATH Environment of JAVA

as you can see below in the screenshot of my CMD the JAVA environment path already set:

so perhaps another cause , do you have any other idea ?

Thanks,

BR,

#

pastedImage_1.png

0 Kudos

16 Views
NXP Employee
NXP Employee

Hello Mohamed,

Currently I cannot reproduce your issue. 

Could you please share your file .tresoslog in folder "tresos\workspace\.metadata". It will help for tracing this issue.

Best regards,

Hung.

0 Kudos

16 Views
NXP Employee
NXP Employee

Hello Mohammed TAOUG,

I guess that you are missing the PATH environment for java.exe. Could you please check it ?

Then please try to open CMD and run the command: 

C:\EB\tresos\..\..\NXP\AUTOSAR\S12Z_AUTOSAR_OS_4_0_80_RTM_1_0_1P2\ssc\bin\generator\sg.exe C:\NXP\AUTOSAR\S12Z_AUTOSAR_OS_4_0_80_RTM_1_0_1P2\os_ts\eclipse\workspace\os_sample_sc1\output\epc\project.epc

0 Kudos