TSN PTP timestamp on on LS1028ARDB switch

cancel
Showing results for 
Search instead for 
Did you mean: 

TSN PTP timestamp on on LS1028ARDB switch

442 Views
jeremy_impson
Contributor III

We are trying to enable TSN on the Layerscape LS1028ARDB development board. We are running the following commands from the LS1028A BSP User Guide, Rev. 0.3, 04/2019.

4.2.13.4.2 Enable timestamp on switch
Follow the following commands to enable timestamp on switch:
#Init PTP:
devmem 0x1fc0900a0 w 0x00000004
#Get PTP real time(second):
devmem 0x1fc0900c4

When I run the first command to enable timestamping:

root@NXP-1:~# devmem 0x1fc0900a0 w 0x00000004

It results in the following error:

-bash: devmem: command not found

After finding this forum post, I installed devmem2 from us.ports.ubuntu.com and ran the following variation of the command, which uses devmem2 instead of devmem:

root@NXP-1:~# devmem2 0x1fc0900a0 w 0x00000004

This is successful:

/dev/mem opened.

Memory mapped at address 0xffffbd909000.

Value at address 0xFC0900A0 (0xffffbd909a0): 0x4

Written 0x4; readback 0x4

Then I run the next command from the User Guide, to see the PTP time:

root@NXP-1:~# devmem 0x1fc0900c4

This results in the following errror:

/dev/mem opened.

Memory mapped at address 0xffff8ea5d000.

Bus error

Questions:

What does this error mean?

How do I see the PTP time?

Is PTP timestamping going to work in the switch?

Where do I find documentation on these addresses? 

When will there be corrected, tested, and verified version of the User Guide for the LS1028ARDB made available so I stop wasting so much time debugging the errors in the current  User Guide? 

Jeremy Impson

Tags (2)
0 Kudos
1 Reply

323 Views
yipingwang
NXP TechSupport
NXP TechSupport

After booting up LS1028ARDB, the following commands could be executed successfully.

root@localhost:/test_dir_new# devmem 0x1fc0900a0 w 0x00000004

root@localhost:/test_dir_new# devmem 0x1fc0900c4

0x0000000C

You could use LSDK 19.09 release, init PTP is enabled in Linux Kernel by default.

0 Kudos