Problem installing 2nd CD of Freescale Linux SDK for QorlQ Processor

cancel
Showing results for 
Search instead for 
Did you mean: 

Problem installing 2nd CD of Freescale Linux SDK for QorlQ Processor

Jump to solution
261 Views
markofrelih
Contributor III

Dear Sirs and Madams!

I have problem installing 2nd CD of Freescale Linux SDK for QorlQ Processor (P2020RDB-PCA Board) since the installation breaks with host-prepare.sh script:

testuser@t61:~/p2020rdb-pca_sdk/QorIQ-SDK-V1.4-20130625-yocto$ ./scripts/host-prepare.shVerifying sudo permission to execute apt-get command.
Now we're going to install all the other development packages needed to build Yocto, please wait
[sudo] password for testuser:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package ia32-libs is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
lib32z1 lib32ncurses5

E: Package 'ia32-libs' has no installation candidate
ERROR: Fail to install pkgs on host! See message above...

Now, I am using Debian 8 system with 64bit kernel:

Linux t61 3.16.0-4-amd64 #1 SMP Debian 3.16.36-1+deb8u2 (2016-10-19) x86_64 GNU/Linux

The problem is I cannot install ia32-libs from repositories nevertheless I've done to manual install the needed library:

sudo dpkg --add-architecture i386

sudo apt-get update

sudo apt-get install ia32-libs

since the error pops up:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Package ia32-libs is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
lib32z1 lib32ncurses5

E: Package 'ia32-libs' has no installation candidate

Are there any workaround?

Sincerely,

Marko

0 Kudos
1 Solution
89 Views
bpe
NXP TechSupport
NXP TechSupport

You should download QorIQ SDK rev. 1.9. Follow the links and instructions above. If you are going to build the target images, download and install the source (common to all supported platforms) and the cache for e500v2 disc images. If you need ready binaries for your target, download the e500v2 images disc image.


Have a great day,
Platon

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

View solution in original post

6 Replies
89 Views
bpe
NXP TechSupport
NXP TechSupport

You are trying to install an extremely old SDK version. Did you try it with a fresher one?


Have a great day,
Platon

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos
89 Views
markofrelih
Contributor III

This version of SDK was shipped with the board yesterday, where can I get new version of it?

Sincerely,

Marko

0 Kudos
89 Views
bpe
NXP TechSupport
NXP TechSupport

The final SDK release for P2020RDB-PCA is 1.9:

https://freescale.sdlproducts.com/LiveContent/content/en-US/QorIQ_SDK/GUID-21A68B1F-4CD4-4959-9175-4...

All customers are strongly recommended to move to that release.

Visit the link below, press the "Download" button, then switch to
the "Previous" tab to get to download links:

http://www.nxp.com/products/microcontrollers-and-processors/more-processors/application-specific-mcu...

Study the documentation available on the source disc image for installation instructions.


Have a great day,
Platon

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos
89 Views
markofrelih
Contributor III

Ok, thanks for the links, however, which SDK file(s) should I download for P2020RDB-PCA board (P2020 CPU), I cannot see its designation in file list, or I just download LINUX-SDK?

0 Kudos
90 Views
bpe
NXP TechSupport
NXP TechSupport

You should download QorIQ SDK rev. 1.9. Follow the links and instructions above. If you are going to build the target images, download and install the source (common to all supported platforms) and the cache for e500v2 disc images. If you need ready binaries for your target, download the e500v2 images disc image.


Have a great day,
Platon

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

View solution in original post

89 Views
markofrelih
Contributor III

This SDK (version 1.4) was shipped with the board to the company yesterday. I was not aware there are new versions of particular SDK, are we talking about same thing?

Sincerely,

Marko

0 Kudos