MSP8360E(power pc) LTIB dependency package issues in ubuntu16.04

cancel
Showing results for 
Search instead for 
Did you mean: 

MSP8360E(power pc) LTIB dependency package issues in ubuntu16.04

1,106 Views
kalaiyarasanpoy
Contributor I

Hi,

I am currently trying to install LTIB in ubuntu16.04.

But I am facing trouble to install the following dependency packages: 

glibc-devel, libstdc++, zlib,  rpm-build.

Log:

Unescaped left brace in regex is deprecated, passed through in regex; marked by <-- HERE in m/%{ <-- HERE ([^}]+)}/ at /home/alpha/Project/RadioRelay/LTIB/MPC8360E/ltib-mpc8360epb-20061208/bin/Ltibutils.pm line 245.
drwxr-xr-x 3 root root 4096 Feb 27 05:29 /usr/include/c++

ltib cannot be run because one or more of the host packages needed
to run it are either missing or out of date.

Please install/upgrade these packages and then re-try.

Package                Minimum ver   Installed info
-------                -----------   ---------------
glibc-devel            0             not installed
libstdc++              0             not installed
zlib                   0             not installed
rpm-build              0             not installed
Died at ./ltib line 1411.

Started: Fri Jun  7 18:09:22 2019
Ended:   Fri Jun  7 18:09:22 2019
Elapsed: 0 seconds

Build Failed

Exiting on error or interrupt

Please help me to solve this problem. Any patch is available for this?

Thanks,

Kalaiyarasan.

Tags (3)
0 Kudos
10 Replies

814 Views
kalaiyarasanpoy
Contributor I

Hi Yiping Wang,

This is my current boot log:

software2@software2-S410:~/ltib/ltib/ltib-mpc8360epb-20081112$ ./ltib
defined(@array) is deprecated at /home/software2/ltib/ltib/ltib-mpc8360epb-20081112/bin/Ltibutils.pm line 378.
(Maybe you should just omit the defined()?)

ltib cannot be run because one or more of the host packages needed
to run it are either missing or out of date.

Please install/upgrade these packages and then re-try.

Package Minimum ver Installed info
------- ----------- ---------------
glibc-devel 0 not installed
zlib 0 not installed
rpm-build 0 not installed
Died at ./ltib line 1209.

Started: Tue Jun 11 19:25:35 2019
Ended: Tue Jun 11 19:25:35 2019
Elapsed: 0 seconds

Build Failed

Exiting on error or interrupt
software2@software2-S410:~/ltib/ltib/ltib-mpc8360epb-20081112$

Thanks,

Kalaiyarasan

0 Kudos

814 Views
kalaiyarasanpoy
Contributor I

Hi Yiping Wang,

I removed all packages inside /opt/freescale and <ltib-install-path>/ before reinstall and build the LTIB. But this time I didn't  find any packages inside  /opt/freescale/ directory. I am getting the same old status build failed. Still I cannot able to install "ia32-libs" package.what could be the problem?

I tried to apply the patch which is mentioned in this link: Compile L3.0.35_4.1.0 on Ubuntu 14.04 64bit OS

but patch was failed.

I have installed ubuntu14.04 along side with windows10(x86_64). It will make any problem?

I was spend around one week on this, so please help me to solve this problem.

Thanks,

Kalaiyarssan

0 Kudos

814 Views
yipingwang
NXP TechSupport
NXP TechSupport

sudo apt-get install libc6:i386 libgcc1:i386 libstdc++5:i386 libstdc++6:i386

0 Kudos

814 Views
Pavel
NXP TechSupport
NXP TechSupport

There is no problem if Ubuntu 12 32bit is used for LTIB.

Ubuntu 14 also can be used.


Have a great day,
Pavel Chubakov

-------------------------------------------------------------------------------
Note:

This thread is continued as a private discussion with the submitter,
NXP support is not following the thread anymore.
-------------------------------------------------------------------------------

0 Kudos

814 Views
kalaiyarasanpoy
Contributor I

Thanks Pavel,

Now I trying to install LTIB in ubuntu14 64 bit system.

0 Kudos

815 Views
vinothkumars
Senior Contributor III

Hi,

Please update the machine (sudo apt-get update, sudo apt-get install) before install the packages.

Thanks & Regards,

VinothS.

Regards,
Vinothkumar Sekar
0 Kudos

815 Views
kalaiyarasanpoy
Contributor I

Hi Vinoth,

It is a fresh ubuntu16 installation in my laptop.

I was upgraded and updated  the ubuntu before start the installation.

Thanks,

Kalaiyarasan

0 Kudos

815 Views
yipingwang
NXP TechSupport
NXP TechSupport

Hello kalaiyarasan Poyyamozhi,

Please refer to the following script to install necessary packages on Ubuntu machine to run ltib.

#/bin/bash
# Install LTIB dependant packages
sudo apt-get install gettext libgtk2.0-dev rpm bison m4 libfreetype6-dev
sudo apt-get install libdbus-glib-1-dev liborbit2-dev intltool
sudo apt-get install ccache ncurses-dev zlib1g zlib1g-dev gcc g++ libtool
sudo apt-get install uuid-dev liblzo2-dev
sudo apt-get install tcl dpkg
# Packages required for 64-bit Ubuntu
# Do "uname -a" and see if the word "x86_64" shows up.
if uname -a|grep -sq 'x86_64'; then
sudo apt-get install ia32-libs libc6-dev-i386 lib32z1
fi

Thanks,

Yiping

0 Kudos

815 Views
kalaiyarasanpoy
Contributor I

Hi Yiping Wang,

Thanks for your reply.

Now I can able install all the packages you mentioned except this   'ia32' .

I am trying with ubuntu 14 x86_64 bit system.

software2@software2-S410:~/ltib/ltib/ltib-mpc8360epb-20081112$ sudo apt-get install ia32-libs libc6-dev-i386 lib32z1
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package ia32-libs is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  lib32z1 lib32ncurses5 lib32bz2-1.0

E: Package 'ia32-libs' has no installation candidate

Thanks,

Kalaiyarasan.

0 Kudos

815 Views
vinothkumars
Senior Contributor III

Kalai,

Please check the system requirements (ubuntu 14 or ubuntu 16) to build. 

Regards,

VinothS.

Regards,
Vinothkumar Sekar
0 Kudos