LS1046ARDB restarts after shutdown

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

LS1046ARDB restarts after shutdown

Jump to solution
1,172 Views
mamorukanou
Contributor IV

Hi,

In rare cases, “shutdown –h now” causes a reboot after shutdown. The average frequency is about once in 10 times. However, there is no regularity in the frequency of occurrence.

If you know the workaround, please let me know.

•Investigation method: Repeat login and shutdown using smart plug (set AC ON / OFF with timer) + teraterm macro. Also, observe the PORESET_B and RESET_REQ_B waveforms of the LS1046A with an oscilloscope.

     HW : LS1046ARDB

     SW : LSDK20.04 (kernel 19.04)

             uname -a

             Linux localhost 4.19.90-dirty #2 SMP PREEMPT Thu Dec 3 16:38:49 JST 2020 aarch64

             aarch64 aarch64 GNU/Linux

•Confirmation result: We confirmed that the restart is occurring in shutdown. Reproduced 4 times out of 46 times. In that case restart is done after 7 seconds after shutdown. At that time, it was confirmed that RESET_REQ_B was issued by LS1046A. This revealed that the SOC was reset.

•I checked it with the kernel without the WDT driver of the Linux kernel, but the phenomenon does not change. It doesn't seem to be a problem with the WDT driver.

BR,

Kanou

0 Kudos
1 Solution
1,141 Views
mamorukanou
Contributor IV

Hi Pavel,

 

Thank you for your reply.

This could be avoided by setting the RPTOE_MSK bit in the RSTRQSR1 register to 1 during the shutdown process.

mamorukanou_0-1620902784159.png

 

Best Regards,

kanou

View solution in original post

0 Kudos
2 Replies
1,148 Views
Pavel
NXP Employee
NXP Employee

Test your board using deep sleep mode.

Find the "Verification in Linux (Use FlexTimer as Wake-up source)" in the Section 7.2.20 in the LSDK 2012 User Guide:

https://www.nxp.com/docs/en/user-guide/LSDKUG_Rev20.12.pdf

 

Set deep sleep mode for 100 seconds or more for testing.

Is there problem for correct deep sleep on your board?

0 Kudos
1,142 Views
mamorukanou
Contributor IV

Hi Pavel,

 

Thank you for your reply.

This could be avoided by setting the RPTOE_MSK bit in the RSTRQSR1 register to 1 during the shutdown process.

mamorukanou_0-1620902784159.png

 

Best Regards,

kanou

0 Kudos