LS1043ARDB can't build ext4 image over the OpenWrt.

cancel
Showing results for 
Search instead for 
Did you mean: 

LS1043ARDB can't build ext4 image over the OpenWrt.

Jump to solution
1,749 Views
d-z-c
Contributor III

Hi guys,I need some help about build some image over the OpenWrt.

Here is my process:

1) Download OpenWrt repository from GitHub: git clone GitHub - openwrt/openwrt: This repository is a mirror of https://git.openwrt.org/openwrt/openwrt.git It is for reference… 

2) Swit to branch openwrt-19.07

 

3) Set menuconfig and make as the attachment file <Porting Openwrt on QorIQ Layerscape ARMv8 Platforms.pdf>

But finally, I can't found any ext4 fs image about the board. It just generate the squashfs image only.

By the way: when I make done, Not any problem is report.

The bin file as below:

--------------------------------------------------------------------------------------------------------------------

$:ls  bin/targets/layerscape/armv8_64b
config.buildinfo
feeds.buildinfo
openwrt-imagebuilder-layerscape-armv8_64b.Linux-x86_64.tar.xz
openwrt-layerscape-armv8_64b-device-ls1043ardb.manifest
openwrt-layerscape-armv8_64b-ls1043ardb-squashfs-firmware.bin
openwrt-sdk-layerscape-armv8_64b_gcc-7.5.0_musl.Linux-x86_64
openwrt-sdk-layerscape-armv8_64b_gcc-7.5.0_musl.Linux-x86_64.tar.xz
openwrt-toolchain-layerscape-armv8_64b_gcc-7.5.0_musl.Linux-x86_64.tar.bz2
packages
sha256sums
version.buildinfo

--------------------------------------------------------------------------------------------------------------------

So,Am I wrong in this process? or some other operations needed?

Happy New year.

2020/1/2

Thanks.

Have a good day.
1 Solution
1,311 Views
yipingwang
NXP TechSupport
NXP TechSupport

Please modify target/linux/layerscape/image/armv8_64b.mk as the following.

define Device/ls1043ardb
  DEVICE_TITLE := LS1043ARDB
  DEVICE_PACKAGES += \
    layerscape-fman-ls1043ardb \
    tfa-ls1043ardb \
    fmc fmc-eth-config
  DEVICE_DTS := freescale/fsl-ls1043a-rdb-sdk
  FILESYSTEMS := ubifs

Then  build image for LS1043ARDB, you will get ubifs in bin/targets/layerscape/armv8_64b/.

View solution in original post

9 Replies
989 Views
suyunfa
Contributor I

ERROR: First slot cannot be empty.
ERROR: Parsing DIMM Error
ERROR: DDR init failed.
NOTICE: Incorrect DRAM0 size is defined in platfor_def.h
ERROR: mmap_add_region_check() failed. error -22
ERROR: mmap_add_region_check() failed. error -22
NOTICE: BL2: v1.5(release):reboot-15563-g3bd8f660a4-dirty
NOTICE: BL2: Built : 12:30:20, Jan 21 2021

I chose the sd card of uboot 1046 to boot. And successfully got openwrt-0.78.1-510a9df2-r15563-3bd8f660a4-layerscape-armv8_64b-fsl_ls1046a-rdb-sdboot-squashfs-sdcard.img
With openwrt-0.78.1-510a9df2-r15563-3bd8f660a4-layerscape-armv8_64b-fsl_ls1046a-rdb-initramfs-kernel.bin
I used penwrt-0.78.1-510a9df2-r15563-3bd8f660a4-layerscape-armv8_64b-fsl_ls1046a-rdb-sdboot-squashfs-sdcard.img
Burn into the tf card. But it prompted an error.
Cannot start normally. Ask for help.

0 Kudos
1,312 Views
yipingwang
NXP TechSupport
NXP TechSupport

Please refer to the attached screenshot, you need to select ext4 in "Target Images".

If your problem remains, please send ".config" in openwrt folder to me to do more investigation.

0 Kudos
1,310 Views
d-z-c
Contributor III

Hi, YiPing

   I have selected the "ext4" in "Target Images" before,here is my .config. Please check.

Thanks.

Have a good day.
0 Kudos
1,310 Views
yipingwang
NXP TechSupport
NXP TechSupport

In OpenWrt, by default ubifs is used for NOR flash, squashfs is used for QSPI flash, ext4 is used by SD card.

Please configure the target as "LS1043ARDB (SD Card Boot)", then build the final image.

Thanks,

Yiping

0 Kudos
1,311 Views
d-z-c
Contributor III

Ok,Now I see ext4 is for SD card. but I also selected ubifs,it dose not generate the ubifs bin image also.

Another question:  I need to burn these files separately,such as : rcw,uboot,kernel...etc. but when I burn the file that path is "build_dir/target-aarch64_generic_musl/uboot-layerscape-ls1043ardb/uboot-layerscape-lsdk-1903/u-boot.bin",

the target address is 0x64100000,It can't boot normally. And log as follow:

NOTICE:  2 GB DDR4, 32-bit, CL=11, ECC off

NOTICE:  BL2: v1.5(release):

NOTICE:  BL2: Built : 08:08:09, Dec 29 2019

ERROR:   BL2: Failed to load image (-2)

Why?

Thanks.

TIC.

Have a good day.
0 Kudos
1,311 Views
yipingwang
NXP TechSupport
NXP TechSupport

Please create a new thread to describe your new question in details.

0 Kudos
1,310 Views
d-z-c
Contributor III

The question never done:"but I also selected ubifs,it dose not generate the ubifs bin image also."The problem hasn't been solved yet.

Have a good day.
0 Kudos
1,312 Views
yipingwang
NXP TechSupport
NXP TechSupport

Please modify target/linux/layerscape/image/armv8_64b.mk as the following.

define Device/ls1043ardb
  DEVICE_TITLE := LS1043ARDB
  DEVICE_PACKAGES += \
    layerscape-fman-ls1043ardb \
    tfa-ls1043ardb \
    fmc fmc-eth-config
  DEVICE_DTS := freescale/fsl-ls1043a-rdb-sdk
  FILESYSTEMS := ubifs

Then  build image for LS1043ARDB, you will get ubifs in bin/targets/layerscape/armv8_64b/.

1,310 Views
d-z-c
Contributor III

Thanks, It really works. I have got a ubifs image in the directory. But It can't boot,I'll create a new thread to ask the question.

Have a good day.
0 Kudos