LS1021A-IOT fail to Building the final images

cancel
Showing results for 
Search instead for 
Did you mean: 

LS1021A-IOT fail to Building the final images

290 Views
david_huang
Contributor I

dear NXP team:

my ubuntu version: ubuntu 64_16.04.3

I got the sdk from github and execute the follow command :

                           1. make nxp_ls1021aiot_defconfig

                           2. make 2>&1 | tee build.log

but i get the error below:

==========================================>

In file included from ../ncurses/curses.priv.h:283:0,
51744 from ../ncurses/lib_gen.c:19:
51745 _18695.c:835:15: error: expected ‘)’ before ‘int’
51746 ../include/curses.h:1594:56: note: in definition of macro ‘mouse_trafo’
51747 #define mouse_trafo(y,x,to_screen) wmouse_trafo(stdscr,y,x,to_screen)
51748 ^
51749 Makefile:795: recipe for target '../obj_s/lib_gen.o' failed
51750 make[2]: *** [../obj_s/lib_gen.o] Error 1

<===========================================

I try to locate the error but i fail to find "_18695.c", can you help me? 

ps: the  attachment is the build.log

thx!

Tags (1)
0 Kudos
4 Replies

110 Views
Pavel
NXP TechSupport
NXP TechSupport

Look at LSDK 1712 documentation:

https://www.nxp.com/docs/en/supporting-information/LSDK-KC-REV0.pdf


Have a great day,
Pavel Chubakov

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

110 Views
david_huang
Contributor I

dear Pavel Chubakov:

according to the step in page 41 of the pdf , I try to find "flexbuild source tarball", but there is only one pdf and no flexbuild tarball on the web.

0 Kudos

110 Views
Pavel
NXP TechSupport
NXP TechSupport

NXP SDK for the LS1021a-IOT board was developed and tested using Ubuntu 14. It is not work under Ubuntu 16. The latest LSDK can be used under Ubuntu 16.


Have a great day,
Pavel Chubakov

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

110 Views
david_huang
Contributor I

dear Pavel Chubakov:

your chinese colleague told me that he tested the SDK using ubuntu16.4 . But now he is on vacatin and I can't reach him, I need your help.

if the latest SDK can work on ubuntu16, where or how can I get the latest one? the SDK I get is from: https://github.com/openil/openil.git

0 Kudos