LS1021A-IOT DHCP configuration not working

cancel
Showing results for 
Search instead for 
Did you mean: 

LS1021A-IOT DHCP configuration not working

571 Views
masranipiyush
Contributor II

Hi,

 

I have build fsl-image-rds and successfully deployed on LS1021A-IOT board. However, the board fails to acquire IP address from DHCP server. I have checked the network configuration and it is set correctly to DHCP as can been seen below in /etc/network/interfaces:

 

# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)

# The loopback interface

auto lo

iface lo inet loopback

# Wireless interfaces

iface wlan0 inet dhcp

        wireless_mode managed

        wireless_essid any

        wpa-driver wext

        wpa-conf /etc/wpa_supplicant.conf

iface atml0 inet dhcp

# Wired or wireless interfaces

auto eth0

iface eth0 inet dhcp

iface eth1 inet dhcp

# Ethernet/RNDIS gadget (g_ether)

# ... or on host side, usbnet and random hwaddr

iface usb0 inet static

        address 192.168.7.2

        netmask 255.255.255.0

        network 192.168.7.0

        gateway 192.168.7.1

# Bluetooth networking

iface bnep0 inet dhcp

 

Please find my console output attached. Can anyone point me to what can be the issue?

 

Thanks.

Piyush

Original Attachment has been moved to: console_output.txt.zip

Tags (2)
2 Replies

189 Views
josefjebavy
Contributor I

Hi,

I have same problem.

Have you somebody solution?

Josef Jebavý

0 Kudos

189 Views
arunsrk91
Contributor II

Hi Piyush,

Have you figure out any solution for this? Am also facing the same issue. Are you able to assign IP and verify internet availibilty over all interfaces (eth0, eth1, wlan0, wlan1)?

@Freescale , I hope some support documents can be provided for configuring the wifi cards and wpa supplicant for LS1021A-IOT.

Thanks and Regards,


Arun S

0 Kudos