Ethernet interface is not working on LS1012ARDB with default yocto build images

cancel
Showing results for 
Search instead for 
Did you mean: 

Ethernet interface is not working on LS1012ARDB with default yocto build images

2,281 Views
srinivasreddyre
Contributor III


I am working on NXP board Model: LS1012A RDB Board, RevB. I am using yocto source LS1012A-SDK-SOURCE-20161230-yocto.iso.

I was able to flash and boot yocto kernel.itb and rootfs from SD card. But with the default yocto build images, Ethernet interface is not working. I have changed the configuration in /etc/network/interfaces to enable the eth0 and eth1 interfaces but still the Ethernet interface is not working.  Ethernet interface is working fine with the default image shipped with LS12012ARDB board. Hope hardware point of view, Ethernet interface is fine. Do I need added any .elf file or make any changes to make Ethernet interface work with yocto source code. Complete log file is attached.

 

==================ifconfig command log  =====================

root@ls1012ardb:~# ifconfig
eth0 Link encap:Ethernet HWaddr 00:04:9f:04:68:b3
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:7 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:1374 (1.3 KiB)

eth1 Link encap:Ethernet HWaddr 00:04:9f:04:70:77
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:5 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:742 (742.0 B)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:19 errors:0 dropped:0 overruns:0 frame:0
TX packets:19 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1197 (1.1 KiB) TX bytes:1197 (1.1 KiB)

==================End of ifconfig command log  =====================

 

==================content of /etc/network/interfaces =====================

root@ls1012ardb:~# cat /etc/network/interfaces
# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)
# The loopback interface
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp

auto eth1
iface eth1 inet dhcp

 

Original Attachment has been moved to: default_yocto_rfs_kernel_13-04-2017.txt.zip

0 Kudos
5 Replies

873 Views
petervollmer
Contributor II

This was already posted on another thread, but I'll repeat it here since it directly answers the initial question.

The interfaces should work after stopping in the u-boot boot prompt and issuing the command

 

=> pfe stop

Stopping PFE...

=> run bootcmd

Without this the kernels seems to fail to work with a PFE that had already been initialized by the bootloader.

Best Regards

Peter

0 Kudos

873 Views
alexander_yakov
NXP Employee
NXP Employee

In your "ifconfig" I do not see IP-addresses assigned to ethernet interfaces eth0 and eth1.

File "/etc/network/interfaces" shows "dhcp" for both eth0 and eth1, this means IP addresses should be obtained from external DHCP server. Do you have DHCP server in your network? In this configuration it will not work without DHCP server.


Have a great day,
Alexander
TIC

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

873 Views
srinivasreddyre
Contributor III

More observation captured below .... 

------------dmesg out log -------------------

root@ls1012ardb:/lib# dmesg
[ 0.199817] RCPM: layerscape_rcpm_init: The RCPM driver initialized.
[ 0.208879] vgaarb: loaded
[ 0.211878] SCSI subsystem initialized
[ 0.216045] libata version 3.00 loaded.
[ 0.216387] usbcore: registered new interface driver usbfs
[ 0.221962] usbcore: registered new interface driver hub
[ 0.227370] usbcore: registered new device driver usb
[ 0.232968] i2c i2c-0: IMX I2C adapter registered
[ 0.237724] i2c i2c-0: can't use DMA
[ 0.241419] pps_core: LinuxPPS API ver. 1 registered
[ 0.246419] pps_core: Software ver. 5.3.6 - Copyright 2005-2007 Rodolfo Giometti <giometti@linux.it>
[ 0.255654] PTP clock support registered
[ 0.259838] No BMan portals available!
[ 0.265440] QMan: Allocated lookup table at ffff000000151000, entry count 65537
[ 0.273007] No QMan portals available!
[ 0.276959] No USDPAA memory, no 'fsl,usdpaa-mem' in device-tree
[ 0.283267] Advanced Linux Sound Architecture Driver Initialized.
[ 0.290588] Switched to clocksource arch_sys_counter
[ 0.308215] NET: Registered protocol family 2
[ 0.313159] TCP established hash table entries: 8192 (order: 4, 65536 bytes)
[ 0.320390] TCP bind hash table entries: 8192 (order: 5, 131072 bytes)
[ 0.327149] TCP: Hash tables configured (established 8192 bind 8192)
[ 0.333672] UDP hash table entries: 512 (order: 2, 16384 bytes)
[ 0.339667] UDP-Lite hash table entries: 512 (order: 2, 16384 bytes)
[ 0.346265] NET: Registered protocol family 1
[ 0.351548] RPC: Registered named UNIX socket transport module.
[ 0.357518] RPC: Registered udp transport module.
[ 0.362291] RPC: Registered tcp transport module.
[ 0.367028] RPC: Registered tcp NFSv4.1 backchannel transport module.
[ 0.373546] PCI: CLS 0 bytes, default 64
[ 0.373966] hw perfevents: Failed to parse /pmu/interrupt-affinity[0]
[ 0.380729] kvm [1]: interrupt-controller@1404000 IRQ6
[ 0.386323] kvm [1]: timer IRQ3
[ 0.389490] kvm [1]: Hyp mode initialized successfully
[ 0.396942] futex hash table entries: 256 (order: 2, 16384 bytes)
[ 0.403237] audit: initializing netlink subsys (disabled)
[ 0.408719] audit: type=2000 audit(0.330:1): initialized
[ 0.415327] HugeTLB registered 2 MB page size, pre-allocated 0 pages
[ 0.422341] VFS: Disk quotas dquot_6.6.0
[ 0.426338] VFS: Dquot-cache hash table entries: 512 (order 0, 4096 bytes)
[ 0.434001] NFS: Registering the id_resolver key type
[ 0.439118] Key type id_resolver registered
[ 0.443360] Key type id_legacy registered
[ 0.447627] fuse init (API version 7.23)
[ 0.452196] 9p: Installing v9fs 9p2000 file system support
[ 0.458844] async_tx: api initialized (async)
[ 0.463311] io scheduler noop registered
[ 0.467322] io scheduler cfq registered (default)
[ 0.473501] PCI host bridge /soc/pcie@3400000 ranges:
[ 0.478609] IO 0x4000010000..0x400001ffff -> 0x00000000
[ 0.484174] MEM 0x4040000000..0x407fffffff -> 0x40000000
[ 0.489870] layerscape-pcie 3400000.pcie: PCI host bridge to bus 0000:00
[ 0.496643] pci_bus 0000:00: root bus resource [bus 00-ff]
[ 0.502182] pci_bus 0000:00: root bus resource [io 0x0000-0xffff]
[ 0.508415] pci_bus 0000:00: root bus resource [mem 0x4040000000-0x407fffffff] (bus address [0x40000000-0x7fffffff])
[ 0.519067] pci 0000:00:00.0: [1957:8100] type 01 class 0x060400
[ 0.519093] pci 0000:00:00.0: reg 0x38: [mem 0x00000000-0x000007ff pref]
[ 0.519139] pci 0000:00:00.0: supports D1 D2
[ 0.519148] pci 0000:00:00.0: PME# supported from D0 D1 D2 D3hot
[ 0.519376] pci 0000:00:00.0: bridge configuration invalid ([bus 00-00]), reconfiguring
[ 0.527561] pci_bus 0000:01: busn_res: [bus 01-ff] end is updated to 01
[ 0.527592] pci 0000:00:00.0: BAR 6: assigned [mem 0x4040000000-0x40400007ff pref]
[ 0.535237] pci 0000:00:00.0: PCI bridge to [bus 01]
[ 0.540452] pcieport 0000:00:00.0: Signaling PME through PCIe PME interrupt
[ 0.547473] pcie_pme 0000:00:00.0:pcie01: service driver pcie_pme loaded
[ 0.547566] aer 0000:00:00.0:pcie02: service driver aer loaded
[ 0.548085] Freescale LS2 console driver
[ 0.553814] fsl-ls2-console: device fsl_mc_console registered
[ 0.559852] fsl-ls2-console: device fsl_aiop_console registered
[ 0.571433] Serial: 8250/16550 driver, 4 ports, IRQ sharing disabled
[ 0.579566] msm_serial: driver initialized
[ 0.584551] console [ttyS0] disabled
[ 0.588189] 21c0500.serial: ttyS0 at MMIO 0x21c0500 (irq = 14, base_baud = 7812500) is a 16550A
[ 0.597020] console [ttyS0] enabled
[ 0.604026] bootconsole [uart0] disabled
[ 0.612701] 21c0600.serial: ttyS1 at MMIO 0x21c0600 (irq = 14, base_baud = 7812500) is a 16550A
[ 0.622618] Unable to detect cache hierarcy from DT for CPU 0
[ 0.638585] brd: module loaded
[ 0.646637] loop: module loaded
[ 0.650556] ahci-qoriq 3200000.sata: AHCI 0001.0301 32 slots 1 ports 6 Gbps 0x1 impl platform mode
[ 0.659544] ahci-qoriq 3200000.sata: flags: 64bit ncq sntf pm clo only pmp fbs pio slum part ccc sds apst
[ 0.671038] scsi host0: ahci-qoriq
[ 0.674695] ata1: SATA max UDMA/133 mmio [mem 0x03200000-0x0320ffff] port 0x100 irq 19
[ 0.684554] fsl-quadspi 1550000.quadspi: s25fl512s (65536 Kbytes)
[ 0.692758] tun: Universal TUN/TAP device driver, 1.6
[ 0.697822] tun: (C) 1999-2004 Max Krasnyansky <maxk@qualcomm.com>
[ 0.706154] Freescale FM module, FMD API version 21.1.0
[ 0.711571] Freescale FM Ports module
[ 0.715244] fsl_mac: fsl_mac: FSL FMan MAC API based driver
[ 0.720935] fsl_dpa: FSL DPAA Ethernet driver
[ 0.725363] fsl_advanced: FSL DPAA Advanced drivers:
[ 0.730350] fsl_proxy: FSL DPAA Proxy initialization driver
[ 0.736001] fsl_dpa_shared: FSL DPAA Shared Ethernet driver
[ 0.741659] fsl_dpa_macless: FSL DPAA MACless Ethernet driver
[ 0.747480] fsl_oh: FSL FMan Offline Parsing port driver
[ 0.752892] e1000: Intel(R) PRO/1000 Network Driver - version 7.3.21-k8-NAPI
[ 0.759950] e1000: Copyright (c) 1999-2006 Intel Corporation.
[ 0.765783] e1000e: Intel(R) PRO/1000 Network Driver - 2.3.2-k
[ 0.771632] e1000e: Copyright(c) 1999 - 2014 Intel Corporation.
[ 0.777619] sky2: driver version 1.30
[ 0.782762] VFIO - User Level meta-driver version: 0.3
[ 0.788360] vfio_fsl_mc_driver_init: Driver registration fails as no fsl_mc_bus found
[ 1.197653] xhci-hcd xhci-hcd.0.auto: xHCI Host Controller
[ 1.203193] xhci-hcd xhci-hcd.0.auto: new USB bus registered, assigned bus number 1
[ 1.211929] xhci-hcd xhci-hcd.0.auto: hcc params 0x0220f66d hci version 0x100 quirks 0x00010010
[ 1.220742] xhci-hcd xhci-hcd.0.auto: irq 22, io mem 0x02f00000
[ 1.227418] hub 1-0:1.0: USB hub found
[ 1.231498] hub 1-0:1.0: 1 port detected
[ 1.235719] xhci-hcd xhci-hcd.0.auto: xHCI Host Controller
[ 1.241253] xhci-hcd xhci-hcd.0.auto: new USB bus registered, assigned bus number 2
[ 1.248989] usb usb2: We don't know the algorithms for LPM for this host, disabling LPM.
[ 1.257876] hub 2-0:1.0: USB hub found
[ 1.261798] hub 2-0:1.0: 1 port detected
[ 1.266051] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[ 1.272627] ehci-pci: EHCI PCI platform driver
[ 1.277156] ehci-platform: EHCI generic platform driver
[ 1.282563] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[ 1.288772] ohci-pci: OHCI PCI platform driver
[ 1.293286] ohci-platform: OHCI generic platform driver
[ 1.298701] usbcore: registered new interface driver usb-storage
[ 1.305689] mousedev: PS/2 mouse device common for all mice
[ 1.311952] i2c /dev entries driver
[ 1.316661] qoriq_cpufreq: Freescale QorIQ CPU frequency scaling driver
[ 1.323436] sdhci: Secure Digital Host Controller Interface driver
[ 1.329625] sdhci: Copyright(c) Pierre Ossman
[ 1.334041] sdhci-pltfm: SDHCI platform and OF driver helper
[ 1.341294] ata1: SATA link down (SStatus 0 SControl 300)
[ 1.347299] sdhci-esdhc 1560000.esdhc: No vmmc regulator found
[ 1.353191] sdhci-esdhc 1560000.esdhc: No vqmmc regulator found
[ 1.400111] mmc0: SDHCI controller on 1560000.esdhc [1560000.esdhc] using ADMA 64-bit
[ 1.408243] sdhci-esdhc 1580000.esdhc: No vmmc regulator found
[ 1.414111] sdhci-esdhc 1580000.esdhc: No vqmmc regulator found
[ 1.460261] mmc1: SDHCI controller on 1580000.esdhc [1580000.esdhc] using ADMA 64-bit
[ 1.469706] caam 1700000.crypto: Instantiated RNG4 SH1
[ 1.474918] caam 1700000.crypto: device ID = 0x0a14040000000000 (Era 8)
[ 1.481560] caam 1700000.crypto: job rings = 4, qi = 0
[ 1.494100] caam 1700000.crypto: caam memcpy support with 4 job rings
[ 1.503529] caam algorithms registered in /proc/crypto
[ 1.510303] caam_jr 1710000.jr: registering rng-caam
[ 1.515535] caam 1700000.crypto: fsl,sec-v5.4 algorithms registered in /proc/crypto
[ 1.523305] MC object device driver fsl_dpaa2_caam registered
[ 1.529664] usbcore: registered new interface driver usbhid
[ 1.535267] usbhid: USB HID core driver
[ 1.540369] fsl-mc bus not found, restool driver registration failed
[ 1.546796] MC object device driver fsl_dpio_drv registered
[ 1.552722] No fsl,qman node
[ 1.555783] Freescale USDPAA process driver
[ 1.559969] fsl-usdpaa: no region found
[ 1.563829] Freescale USDPAA process IRQ driver
[ 1.569021] MC object device driver fsl_dpaa2_eth registered
[ 1.574756] MC object device driver dpaa2_mac registered
[ 1.580119] MC object device driver dpaa2_ethsw registered
[ 1.585642] MC object device driver dpaa2_evb registered
[ 1.591003] MC object device driver fsl_dce_api registered
[ 1.596526] MC object device driver dpaa2_rtc registered
[ 1.603457] Initializing XFRM netlink socket
[ 1.607836] NET: Registered protocol family 10
[ 1.613417] sit: IPv6 over IPv4 tunneling driver
[ 1.618623] NET: Registered protocol family 17
[ 1.623143] NET: Registered protocol family 15
[ 1.627641] 8021q: 802.1Q VLAN Support v1.8
[ 1.631878] 9pnet: Installing 9P2000 support
[ 1.636234] Key type dns_resolver registered
[ 1.641883] registered taskstats version 1
[ 1.646479] fsl_generic: FSL DPAA Generic Ethernet driver
[ 1.652118] hctosys: unable to open rtc device (rtc0)
[ 1.657667] ALSA device list:
[ 1.660679] No soundcards found.
[ 1.664606] Waiting 5 sec before mounting root device...
[ 1.676198] mmc0: new high speed SDHC card at address aaaa
[ 1.682133] mmcblk0: mmc0:aaaa SL16G 14.8 GiB
[ 1.691821] mmcblk0: p1
[ 1.709262] mmc1: queuing unknown CIS tuple 0x80 (7 bytes)
[ 1.717026] mmc1: queuing unknown CIS tuple 0x80 (6 bytes)
[ 1.725344] mmc1: queuing unknown CIS tuple 0x80 (8 bytes)
[ 1.731972] mmc1: queuing unknown CIS tuple 0x80 (2 bytes)
[ 1.739995] mmc1: queuing unknown CIS tuple 0x80 (7 bytes)
[ 1.747466] mmc1: queuing unknown CIS tuple 0x80 (5 bytes)
[ 1.762678] mmc1: new high speed SDIO card at address 0001
[ 6.675379] EXT2-fs (mmcblk0p1): warning: mounting unchecked fs, running e2fsck is recommended
[ 6.688705] VFS: Mounted root (ext2 filesystem) on device 179:1.
[ 6.695789] devtmpfs: mounted
[ 6.699129] Freeing unused kernel memory: 476K (ffff800000b5e000 - ffff800000bd5000)
[ 6.706957] Freeing alternatives memory: 48K (ffff800000bd5000 - ffff800000be1000)
[ 7.356385] udevd[924]: starting version 182
[ 7.477922] pfe: module is from the staging directory, the quality is unknown, you have been warned.
[ 7.535517] cbus_baseaddr: ffff000000600000, ddr_baseaddr: ffff800003400000, ddr_phys_baseaddr: 83400000, ddr_size: c00000
[ 7.546648] pfe_hw_init
[ 7.549093] CLASS version: 20
[ 7.552071] TMU version: 1011231
[ 7.555300] BMU1 version: 21
[ 7.558179] BMU2 version: 21
[ 7.561068] EGPI1 version: 50
[ 7.564035] EGPI2 version: 50
[ 7.567001] HGPI version: 50
[ 7.569880] GPT version: 0
[ 7.572594] HIF version: 10
[ 7.575387] HIF NOPCY version: 10
[ 7.578703] bmu_init(1) done
[ 7.581593] bmu_init(2) done
[ 7.586697] class_init() done
[ 7.599702] tmu_init() done
[ 7.602504] gpi_init(1) done
[ 7.605386] gpi_init(2) done
[ 7.608267] gpi_init(hif) done
[ 7.611327] bmu_enable(1) done
[ 7.614381] bmu_enable(2) done
[ 7.617435] pfe_hif_lib_init
[ 7.620518] pfe_hif_init
[ 7.623050] pfe_hif_alloc_descr
[ 7.828735] random: rngd urandom read with 21 bits of entropy available
[ 9.278400] pfe_hif_init_buffers
[ 9.282576] pfe_firmware_init
[ 9.310735] pfe_load_elf
[ 9.313297] pe_load_ddr_section: load address(3fb0000) and elf file address(ffff000000515000) rcvd
[ 9.346732] PFE binary version: pfe_ls1012a_00_2
[ 9.351368] pfe_firmware_init: class firmware loaded 0xa60 0xc3010000
[ 9.357817] pfe_load_elf
[ 9.361376] pfe_firmware_init: tmu firmware loaded 0x200
[ 9.366713] pfe_ctrl_init
[ 9.395294] pfe_ctrl_init finished
[ 9.398710] pfe_eth_init
[ 9.401345] pfe_eth_mdio_init
[ 9.404554] pfe_ctrl_timer
[ 9.422446] libphy: Comcerto MDIO Bus: probed
[ 9.428719] pfe_phy_init interface 3
[ 9.510673] eth0: pfe_eth_init_one: created interface, baseaddr: ffff000000800000
[ 9.519826] pfe_phy_init interface 7
[ 9.529491] eth0: pfe_eth_open
[ 9.532934] hif_process_client_req: register client_id 0
[ 9.538252] pfe_hif_client_register
[ 9.541769] eth0: pfe_gemac_init
[ 9.600720] eth1: pfe_eth_init_one: created interface, baseaddr: ffff000000820000
[ 9.608291] pfe_debugfs_init
[ 9.782426] eth1: pfe_eth_open
[ 9.785856] hif_process_client_req: register client_id 1
[ 9.791216] pfe_hif_client_register
[ 9.794719] eth1: pfe_gemac_init
[ 12.667994] bridge: automatic filtering via arp/ip/ip6tables has been deprecated. Update your scripts to load br_netfilter if you need this.
[ 12.687283] device virbr0-nic entered promiscuous mode
[ 12.946654] device virbr0-nic left promiscuous mode
[ 12.951610] virbr0: port 1(virbr0-nic) entered disabled state
[ 13.600415] eth1: Link is Up - 1Gbps/Full - flow control rx/tx
[ 28.760134] random: nonblocking pool is initialized

------------------------end of dmesg -----------------------

----------------------------lsmod command output ---------------
root@ls1012ardb:/lib# lsmod
Module Size Used by
bridge 85872 0
stp 2331 1 bridge
llc 5952 2 stp,bridge
pfe 85725 0

-------------------------end of lsmod log ------------------------- 

-------------------------ifconfig command output -------------------
root@ls1012ardb:/lib#
root@ls1012ardb:/lib# ifconfig
eth0 Link encap:Ethernet HWaddr 00:04:9f:04:68:b3
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:612 (612.0 B)

eth1 Link encap:Ethernet HWaddr 00:04:9f:04:70:77
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:169 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:57042 (55.7 KiB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:21 errors:0 dropped:0 overruns:0 frame:0
TX packets:21 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1295 (1.2 KiB) TX bytes:1295 (1.2 KiB)

-----------------------end of ifconfig ------------------

In ifconfig, the  mac address for eth0 is read wrongly as 00:04:9f:04:68:b3 but on the bot it is written as   00:04:9f:04:70:76  and mac address for eth1 is read as correctly.

Let me know if you required any debug log from my side...

0 Kudos

873 Views
srinivasreddyre
Contributor III

The kernel detects eth0 and eth1 interfaces, a link is also detected on both interfaces, but packets between the board and a peer can not be sent or  received.  I have used the .elf file from the below site but there is no packet flow between peer and board. am I, missing any configuration for PFE?  please suggest...

pfe_firmware - vendor/mindspeed/drivers - Git at Google 

0 Kudos

873 Views
srinivasreddyre
Contributor III

Hi Alexander,

Thanks for your inputs.

Yes, I have DHCP server running in my network.

Connected test PC and LS1012ARDB board in the same network. 

In the above attached log, there are some error and warning message related to Ethernet interface.

Listing the same below... 

---------------Error message -------------------------------

"INIT: Entering runlevel: 5
Configuring network interfaces... eth0: ERROR while getting interface flags: No such device
eth1: ERROR while getting interface flags: No such device "

---------------End of error message ------------------------

----------------warning message --------------------

"2017-03-29 05:24:05.989+0000: 1505: info : libvirt version: 1.2.19
2017-03-29 05:24:05.989+0000: 1505: warning : virGetHostname:667 : getaddrinfo failed for 'ls1012ardb': Temporary failure in name resolution
Starting crond: OK"

----------------End of warning message --------------------

To narrow donw the issue, i have  assigned static IP for LS1012ARDB, still the Ethernet interface is not working. Configuration and observation captured below. It look like ping packet is not going out. Could you please share me the kernel configuration to enable Ethernet interface.

root@ls1012ardb:~# cat /etc/network/interfaces
# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)

# The loopback interface
auto lo
iface lo inet loopback


auto eth0
iface eth0 inet manual

auto eth1
iface eth1 inet static
address 192.170.0.254
netmask 255.255.0.0
gateway 192.170.0.1

------------after reboot, ifconfig result  ---------------------------

root@ls1012ardb:~# ifconfig
eth1 Link encap:Ethernet HWaddr 00:04:9f:04:70:77
inet addr:192.170.0.254 Bcast:192.170.255.255 Mask:255.255.0.0
inet6 addr: fe80::204:9fff:fe04:7077/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:10 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:868 (868.0 B)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:19 errors:0 dropped:0 overruns:0 frame:0
TX packets:19 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1197 (1.1 KiB) TX bytes:1197 (1.1 KiB)

------------------ping result -----------------------------------

root@ls1012ardb:~# ping 192.170.0.1
PING 192.170.0.1 (192.170.0.1) 56(84) bytes of data.
From 192.170.0.254 icmp_seq=1 Destination Host Unreachable
From 192.170.0.254 icmp_seq=2 Destination Host Unreachable
From 192.170.0.254 icmp_seq=3 Destination Host Unreachable

0 Kudos