Adding a compiled binary to rootfs in Yocto fails (QorIQ SDK 1.8)

cancel
Showing results for 
Search instead for 
Did you mean: 

Adding a compiled binary to rootfs in Yocto fails (QorIQ SDK 1.8)

1,813 Views
janbrand
Contributor II


Hi,

i'm trying to copy a file to the /home/root/ directory to my rootfs for my target. I want to use the merge-files recipe for that:

-  I copied my helloworld.out binary to /QorIQ-SDK-V1.8-20150619-yocto/meta-fsl-arm/recipes-extended/merge-files/merge-files/merge/helloworld.out

-  I didn't touched the merge-files_1.0.bb

-  in my target .bb - file i added   merge-files    to IMAGE_INSTALL.

But when I try to bitbake the target the following errors appear:

Build Configuration:

BB_VERSION        = "1.22.0"

BUILD_SYS         = "x86_64-linux"

NATIVELSBSTRING   = "Ubuntu-14.04"

TARGET_SYS        = "arm-fsl-linux-gnueabi"

MACHINE           = "ls1021atwr"

DISTRO            = "fsl-networking"

DISTRO_VERSION    = "QorIQ-SDK-V1.8"

TUNE_FEATURES     = "armv7a vfp neon callconvention-hard cortexa7"

TARGET_FPU        = "vfp-neon"

meta             

meta-yocto       

meta-yocto-bsp    = "daisy:18837ea4cdd4fdab608e0a032a11a2dfb6b1ee1a"

meta-fsl-arm      = "daisy:b529ac5ba06a0d69d7e6e295776a4d684c6e1c56"

meta-fsl-networking = "daisy:6eb28ed659bbadfa470237dfce98bcbf53c18fe1"

meta-fsl-toolchain = "daisy:a253b3594d8d9e0a4ed869d1fb502c395c4438ac"

meta-virtualization = "daisy:df44ec7a68c8e4b713a458a5b93e903103dea85c"

meta-oe          

meta-networking  

meta-perl        

toolchain-layer   = "daisy:4a44c4107899363b22c01eb5621b0c86db1c659c"

meta-java         = "daisy:65c89b93fa9d4c89e1dfb5b795075cbadb541009"

meta-linaro-toolchain = "daisy:9e742fbb8cbb6d2087fb41429a77fcf0ce50dbb8"

meta-security     = "daisy:9f4c3849521465b459845dcc1a7a885bacaae9d9"

NOTE: Preparing runqueue

NOTE: Executing SetScene Tasks

NOTE: Executing RunQueue Tasks

NOTE: Running task 1157 of 1825 (ID: 778, /home/devel/QorIQ-SDK-V1.8-20150619-yocto/meta-fsl-arm/recipes-extended/merge-files/merge-files_1.0.bb, do_fetch)

NOTE: recipe merge-files-1.0-r0: task do_fetch: Succeeded

NOTE: Running task 1761 of 1825 (ID: 774, /home/devel/QorIQ-SDK-V1.8-20150619-yocto/meta-fsl-arm/recipes-extended/merge-files/merge-files_1.0.bb, do_unpack)

NOTE: recipe merge-files-1.0-r0: task do_unpack: Succeeded

NOTE: Running task 1814 of 1825 (ID: 775, /home/devel/QorIQ-SDK-V1.8-20150619-yocto/meta-fsl-arm/recipes-extended/merge-files/merge-files_1.0.bb, do_patch)

NOTE: recipe merge-files-1.0-r0: task do_patch: Succeeded

NOTE: Running noexec task 1815 of 1825 (ID: 779, /home/devel/QorIQ-SDK-V1.8-20150619-yocto/meta-fsl-arm/recipes-extended/merge-files/merge-files_1.0.bb, do_configure)

NOTE: Running noexec task 1816 of 1825 (ID: 780, /home/devel/QorIQ-SDK-V1.8-20150619-yocto/meta-fsl-arm/recipes-extended/merge-files/merge-files_1.0.bb, do_compile)

NOTE: Running task 1817 of 1825 (ID: 776, /home/devel/QorIQ-SDK-V1.8-20150619-yocto/meta-fsl-arm/recipes-extended/merge-files/merge-files_1.0.bb, do_install)

NOTE: Running task 1818 of 1825 (ID: 781, /home/devel/QorIQ-SDK-V1.8-20150619-yocto/meta-fsl-arm/recipes-extended/merge-files/merge-files_1.0.bb, do_populate_lic)

NOTE: recipe merge-files-1.0-r0: task do_populate_lic: Succeeded

NOTE: recipe merge-files-1.0-r0: task do_install: Succeeded

NOTE: Running task 1819 of 1825 (ID: 784, /home/devel/QorIQ-SDK-V1.8-20150619-yocto/meta-fsl-arm/recipes-extended/merge-files/merge-files_1.0.bb, do_package)

NOTE: Running task 1820 of 1825 (ID: 777, /home/devel/QorIQ-SDK-V1.8-20150619-yocto/meta-fsl-arm/recipes-extended/merge-files/merge-files_1.0.bb, do_populate_sysroot)

ERROR: Error executing a python function in /home/devel/QorIQ-SDK-V1.8-20150619-yocto/meta-fsl-arm/recipes-extended/merge-files/merge-files_1.0.bb:

The stack trace of python calls that resulted in this exception/failure was:

File: 'do_package_qa', lineno: 88, function: <module>

     0084:        bb.fatal("QA run found fatal errors. Please consider fixing them.")

     0085:    bb.note("DONE with PACKAGE QA")

     0086:

     0087:

*** 0088:do_package_qa(d)

     0089:

File: 'do_package_qa', lineno: 71, function: do_package_qa

     0067:            package_qa_handle_error("pkgname",

     0068:                    "%s doesn't match the [a-z0-9.+-]+ regex\n" % package, d)

     0069:

     0070:        path = "%s/%s" % (pkgdest, package)

*** 0071:        if not package_qa_walk(path, warnchecks, errorchecks, skip, package, d):

     0072:            walk_sane  = False

     0073:        if not package_qa_check_rdepends(package, pkgdest, skip, d):

     0074:            rdepends_sane = False

     0075:        if not package_qa_check_deps(package, pkgdest, skip, d):

File: 'insane.bbclass', lineno: 19, function: package_qa_walk

     0015:                elf = None

     0016:            for func in warnfuncs:

     0017:                func(path, package, d, elf, warnings)

     0018:            for func in errorfuncs:

*** 0019:                func(path, package, d, elf, errors)

     0020:

     0021:    for w in warnings:

     0022:        bb.warn("QA Issue: %s" % w)

     0023:        package_qa_write_error(w, d)

File: 'insane.bbclass', lineno: 25, function: package_qa_check_arch

     0021:        return

     0022:

     0023:    #if this will throw an exception, then fix the dict above

     0024:    (machine, osabi, abiversion, littleendian, bits) \

*** 0025:        = package_qa_get_machine_dict()[target_os][target_arch]

     0026:

     0027:    # Check the architecture and endiannes of the binary

     0028:    if not ((machine == elf.machine()) or \

     0029:        ((("virtual/kernel" in provides) or bb.data.inherits_class("module", d) ) and (target_os == "linux-gnux32"))):

Exception: KeyError: 'allarch'

ERROR: Function failed: do_package_qa

NOTE: recipe merge-files-1.0-r0: task do_package: Failed

ERROR: Task 784 (/home/devel/QorIQ-SDK-V1.8-20150619-yocto/meta-fsl-arm/recipes-extended/merge-files/merge-files_1.0.bb, do_package) failed with exit code '1'

NOTE: recipe merge-files-1.0-r0: task do_populate_sysroot: Succeeded

NOTE: Tasks Summary: Attempted 1820 tasks of which 1811 didn't need to be rerun and 1 failed.

As you can see my board is a TWR-LS1021a . The Chip-Revision is 1.0.

What I'm doing wrong?

kind regards,

Jan

0 Kudos
3 Replies

395 Views
bpe
NXP TechSupport
NXP TechSupport

There are some problems with Python on Ubuntu 14.04. Check the thread at the link below, there seem to be a solution:

Why does the 1043ARDB fsl-image-full build fail?


Have a great day,
Platon

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

395 Views
janbrand
Contributor II

I followed the steps given in the discussion, but that doesn't worked for me. The problem is exactly the same....

What can i do?

kind regards,

Jan

0 Kudos

395 Views
pro-supportengi
NXP Employee
NXP Employee

Hi Jan, if you did not already resolve the python issues, it might be due to the version of Ubuntu 14.04 you are using.

Ubuntu 14.04.3 (32 bit or 64 bit) builds we found to build successfully, but 14.04.1 LTS (32 or 64 bit) failed. My python3 version is 3.4.0 for the 14.04.1 LTS (32-bit).  I installed Ubuntu 14.04.3 (14.04.3-desktop-amd64.iso) and this built successfully.

Although uname -a gives the following:

Linux Latitude-E7440 3.19.0-25-generic #26~14.04.1-Ubuntu SMP Fri Jul 24 21:16:20 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

I installed 14.04.3 below and this worked fine. Get the ISO from the Ubuntu site. http://releases.ubuntu.com/14.04/ubuntu-14.04.3-desktop-amd64.iso.  That's Trusty Tahir - Long Term Stable. Simply follow the instructions to install.  If using Ubuntu, you can create a bootable USB stick containing the bootable .iso image: http://www.ubuntu.com/download/desktop/create-a-usb-stick-on-ubuntu. Similarly, on windows you can use the Windows USB/DVD Download Tool: https://www.microsoft.com/en-us/download/windows-usb-dvd-download-tool

0 Kudos