Access GPIO pins ls1012a-rdb

cancel
Showing results for 
Search instead for 
Did you mean: 

Access GPIO pins ls1012a-rdb

228 Views
adam_masoud
Contributor I

Hello Community,

I am currently trying to access the GPIO pins located on the ls1012ardb expansion headers and having no luck. I have used QCVS to configure the PBL component and assigned GPIO as the function for all parameters involving SDHC1. The file successfully boots up and I then try using commands to configure the GPIO pins i.e

   

   # cd /sys/class/gpio

   # echo 447 > export

   # echo out > gpio447/direction

   # echo 1 > gpio447/value

I have done this for every GPIO I could export and with a simple LED circuit connected to a single pin (pin 14 on the J17 header) I get no result.

So my questions are;

1. I was wondering if anybody would be able to help me out with accessing GPIOs on the Arduino headers?

2. Also if anyone knows the corresponding pin numbers in linux for the digital I/O pins, that would be extremely helpful?

Thanks in advance,

Adam

0 Kudos
3 Replies

65 Views
Pavel
NXP TechSupport
NXP TechSupport

Try to disable mmc using .dts file for the LS1021a-rdb board.


Have a great day,
Pavel Chubakov

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

65 Views
Pavel
NXP TechSupport
NXP TechSupport

Check the SW2 setting on your LS1012ARDB board.

See the Section 2.13.2 of the LS1012ARDB Manual:

https://www.nxp.com/webapp/Download?colCode=LS1012ARDBRM&Parent_nodeId=1462294874819702554554&Parent...

 

Check the RCW[SDHC2_BASE_DAT321],RCW[SDHC2_BASE_BASE], and RCW[SDHC2_EXT_*] fields fields on your board. See the Section 3.4.4 of the LS1012a Reference Manual.


Have a great day,
Pavel Chubakov

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

65 Views
adam_masoud
Contributor I

Hi Pavel,

Apologies for late response. When I change the DiP switches to enable GPIO (SW2[1:0] = 01), as it mentions in the reference manual, the board does not boot for rome reason. It is probably worth mentioning that I have tried the RCW file I generated for GPIO Access on an LS1012A Freedom board and it works totally fine. So I am unsure why his works on the freedom board but not the RDB. I know it is probably because of the SD reader but according to the QCVS tool on CodeWarrior all of the SDHC_2 pins have GPIO functionality enabled.

This is the error I am getting with the RDB as soon as I plug anthing into the GPIO number 16 on header J17, but this pin works totally fine on the freedom board.

pastedImage_271.png

0 Kudos