A question about LS1043ARDB can't mount rootfs with the ubifs image.

cancel
Showing results for 
Search instead for 
Did you mean: 

A question about LS1043ARDB can't mount rootfs with the ubifs image.

88 Views
Contributor II

Hi, 

Then I have got a openwrt-layerscape-armv8_64b-ls1043ardb-ubifs-firmware.bin in bin/targets/layerscape/armv8_64b/.

by the thread:https://community.nxp.com/thread/521286 

But when I burned it into the norflash, It can't mount the ubifs rootfs,And I wonder about why the uboot env is not change to boot the ubifs?

The bootargs is:

root=/dev/mtdblock8 rootfstype=squashfs,jffs2 noinitrd earlycon=uart8250,mmio,0x21c0500 console=ttyS0,115200 mtdparts=60000000.nor:1m(bl2),4m(fip),1m(u-boot-env),3m(reserved-1),256k(fman),5888k(reserved-2),1m(dtb),16m(kernel),32m(rootfs)

So I modified it to(Reference LS1012A):

ubi.mtdblock=8 root=ubi0:rootfs rw rootfstype=ubifs, noinitrd earlycon=uart8250,mmio,0x21c0500 console=ttyS0,115200 mtdparts=60000000.nor:1m(bl2),4m(fip),1m(u-boot-env),3m(reserved-1),256k(fman),5888k(reserved-2),1m(dtb),16m(kernel),32m(rootfs)

The Kernel log is that:

[ 2.901703] ubi0: attaching mtd8
[ 2.908726] ubi0: scanning is finished
[ 2.912481] ubi0 error: ubi_read_volume_table: the layout volume was not found
[ 2.919714] ubi0 error: ubi_attach_mtd_dev: failed to attach mtd8, error -22
[ 2.926766] UBI error: cannot attach mtd8

What's wrong about this issue?

Kind wishes.

Thanks.

0 Kudos
1 Reply

11 Views
NXP TechSupport
NXP TechSupport

Please refer to the following boot environment.

=> pri bootcmd
bootcmd=run lede_boot
=> pri lede_boot
lede_boot=run lede_setenv;run lede_run
=> pri lede_setenv
lede_setenv=setenv loadaddr 82000000 && setenv fdtaddr 8f000000 && setenv bootargs ubi.mtd=9 root=ubi0:rootfs rw rootfstype=ubifs noinitrd earlycon=uart8250,mmio,0x21c0500 console=ttyS0,115200 mtdparts=1550000.quadspi:1M(rcw),2M(u-boot),1M(u-boot-env),5M(reserved-1),256k(fman),5888k(reserved-2),1M(dtb),16M(kernel),32M(ubifs)
=> pri lede_run
lede_run=sf probe 0:0 && sf read $fdtaddr f00000 100000 && sf read $loadaddr 1000000 1000000 && bootm $loadaddr - $fdtaddr
=>

0 Kudos