RDVCU5775EVM SBC problems

cancel
Showing results for 
Search instead for 
Did you mean: 

RDVCU5775EVM SBC problems

Jump to solution
966 Views
mayao999
Contributor I

Hi, I'm using the RDVCU5775EVM board for BMS development, the board is connect the 12V power supply on connector J8's A11 and A21, when I power up with the jumper J1(SBC debug pin) attached, the board can power-up correctly(I have download the demo BMS program inside the MCU), and the promgramming is running, because the LED GPIO1&2  blink. But, when I remove the jumper J1, and power up board again, I can see the led D54(reset) blink several times and the board power down. I guess the KL15_WAKE is using for wake up the SBC and I try to connect the KL15_wake to +12V, the board just powered like 2 seconds and shut down as well.

So, my question is:

1, My connection correct or not?

2, Does LED D54 blink during reset term is correct? 

3, How to set up the SBC during reset term?

Thanks for helping!

Best regards,

0 Kudos
1 Solution
930 Views
davidtosenovjan
NXP TechSupport
NXP TechSupport

And also forwarding another his comment:

I have reproduced this problem in SDK-based projects at the O0 level of GCC optimization, but it works at the O1, O2, and O3 levels.

At the O0 level, it exceeds the maximum time 256ms of SBC first watchdog refresh, I'm working on fixing the issue.

Current workaround: Change the GCC optimization level to at least O1.

View solution in original post

0 Kudos
4 Replies
931 Views
davidtosenovjan
NXP TechSupport
NXP TechSupport

And also forwarding another his comment:

I have reproduced this problem in SDK-based projects at the O0 level of GCC optimization, but it works at the O1, O2, and O3 levels.

At the O0 level, it exceeds the maximum time 256ms of SBC first watchdog refresh, I'm working on fixing the issue.

Current workaround: Change the GCC optimization level to at least O1.

0 Kudos
884 Views
mayao999
Contributor I

Thanks David!

0 Kudos
930 Views
davidtosenovjan
NXP TechSupport
NXP TechSupport

I have forwarded these question to RDVCU5775EVM project owner and here there are the answers:

1, My connection correct or not?
Correct.

2, Does LED D54 blink during reset term is correct?
It shouldn’t blink several times. That indicates the MCU failed to refresh the SBC watchdog during the 256ms from power-up in the non-debug mode.

3, How to set up the SBC during reset term?
Make sure that MCU refreshes the SBC watchdog during the 256ms from power-up.

Now the SDK-based project we provided has an issue that can’t refresh SBC watchdog first time under the O0 optimization level for GCC, I’m working on fixing this issue, suggest the user change the GCC optimization level to at least O1, that is ok I tested.

0 Kudos
307 Views
Ckh091020
Contributor I

I have an issue with my VCU board ( RDVCU5775EVM) , I uploaded a BL into the Chip , there might be some error during the upload process, the board reset itself , and ever since the load, there is only one LED stay on( D55),  For D56,D57,D58,D59 will stay on for first second or so then turn off , I powered the VBAT , and GND , whenever power is supplied to SBC_WAKE , it is doing the same thing, it is doing the same thing regardless J1 jumper being open or closed. My question is for the SBC , is there anyways I can keep the power on so I can reload the BL ? during that split second, PE software able to recognize the chips, so I think it is SBC is doing something and shut the power to provide to the MCU.

0 Kudos