bitbake error, QorIQ SDK v1.4, Ubuntu 12.0.4

cancel
Showing results for 
Search instead for 
Did you mean: 

bitbake error, QorIQ SDK v1.4, Ubuntu 12.0.4

3,441 Views
andreb
Contributor I

Hello community, thanks for considering this problem.

I've been trying to build the SDK via bitbake.  I've never used bitbake before, just a disclaimer, and I am sort of following this process blindly.  I installed the cache, and followed the directions up to this point, setting up the system for the p1010 processor.

I've tried several different bitbake builds, including:

bitbake fsl-image-minimal

bitbake fsl-image-core

bitbake fsl-image-full

And the build has yet to complete, and always gives the following error shown below.  Any help is greatly appreciated.

:~/QorIQ-SDK-V1.4-20130625-yocto/build_p1010rdb_release$ bitbake fsl-image-minimal

Loading cache: 100% |###########################################################################################################| ETA:  00:00:00

Loaded 1757 entries from dependency cache.

Build Configuration:

BB_VERSION = "1.18.0"

BUILD_SYS = "i686-linux"

NATIVELSBSTRING = "Ubuntu-12.04"

TARGET_SYS = "powerpc-fsl_networking-linux-gnuspe"

MACHINE = "p1010rdb"

DISTRO = "fsl-networking"

DISTRO_VERSION = "1.4"

TUNE_FEATURES = "m32 spe ppce500v2"

TARGET_FPU = "ppc-efd"

meta

meta-yocto

meta-yocto-bsp = "sdk-v1.4.x:5a7532143a49f59a5c85b08d3daf574fb1eccd8d"

meta-fsl-ppc = "sdk-v1.4.x:f9fd0a617eb6913f87335c551918315ff4ebe18c"

meta-fsl-ppc-toolchain = "sdk-v1.4.x:8ec94cec04527cb971c125b1ddd2c5375034d723"

meta-virtualization = "sdk-v1.4.x:ad6df4f59cd7646f61db29e8fa51f878329d6f93"

meta-fsl-networking = "(nobranch):00f7a535029ca7ef8c96ba8e9916d4742166bab0"

meta-oe

meta-networking = "sdk-v1.4.x:7c8dd8f096b64a709175d37a08a4fb02ca263616"

NOTE: Resolving any missing task queue dependencies

NOTE: Preparing runqueue

NOTE: Executing SetScene Tasks

NOTE: Executing RunQueue Tasks

ERROR: Function failed: do_compile (see /home/developer/QorIQ-SDK-V1.4-20130625-yocto/build_p1010rdb_release/tmp/work/p1010rdb-fsl_networking-linux-gnuspe/u-boot/git-r33/temp/log.do_compile.6127 for further information)

ERROR: Logfile of failure stored in: /home/developer/QorIQ-SDK-V1.4-20130625-yocto/build_p1010rdb_release/tmp/work/p1010rdb-fsl_networking-linux-gnuspe/u-boot/git-r33/temp/log.do_compile.6127

Log data follows:

| DEBUG: Executing shell function do_compile

| NOTE: make -j 2 CROSS_COMPILE=powerpc-fsl_networking-linux-gnuspe- CC=powerpc-fsl_networking-linux-gnuspe-gcc --sysroot=/home/developer/QorIQ-SDK-V1.4-20130625-yocto/build_p1010rdb_release/tmp/sysroots/p1010rdb O=P1010RDB_NAND distclean

| Makefile:598: *** missing `endif'.  Stop.

| ERROR: oe_runmake failed

| ERROR: Function failed: do_compile (see /home/developer/QorIQ-SDK-V1.4-20130625-yocto/build_p1010rdb_release/tmp/work/p1010rdb-fsl_networking-linux-gnuspe/u-boot/git-r33/temp/log.do_compile.6127 for further information)

ERROR: Task 308 (/home/developer/QorIQ-SDK-V1.4-20130625-yocto/meta-fsl-ppc/recipes-kernel/u-boot/u-boot_git.bb, do_compile) failed with exit code '1'

NOTE: Tasks Summary: Attempted 1212 tasks of which 1204 didn't need to be rerun and 1 failed.

Waiting for 0 running tasks to finish:

Summary: 1 task failed:

/home/developer/QorIQ-SDK-V1.4-20130625-yocto/meta-fsl-ppc/recipes-kernel/u-boot/u-boot_git.bb, do_compile

Summary: There was 1 ERROR message shown, returning a non-zero exit code.

Labels (1)
0 Kudos
6 Replies

195 Views
John_Kaz
NXP Employee
NXP Employee


Did you go through all the host environment setup as explained in the following link?

http://www.freescale.com/infocenter/index.jsp?topic=%2FQORIQSDK%2F2880375.html

Specifically:

$ . /scripts/host-prepare.sh

$ sudo dpkg-reconfigure --terse -f readline dash

$ sudo apt-get install sed wget subversion git-core coreutils unzip

texi2html texinfo libsdl1.2-dev docbook-utils fop gawk python-pysqlite2

diffstat make gcc build-essential xsltproc g++ desktop-file-utils

chrpath libgl1-mesa-dev libglu1-mesa-dev autoconf automake groff libtool

xterm libxml-parser-perl vim-common xz-utils cvs tofrodos

libstring-crc32-perl ubuntu-minimal ubuntu-standard patch

libbonobo2-common libncurses5-dev

Extra packages are needed for Ubuntu-64b

$ sudo apt-get install ia32-libs lib32ncurses5-dev

$ source ./fsl-setup-poky -m p1010rdb

0 Kudos

195 Views
andreb
Contributor I

John, thanks for responding to me.

When I first went through the procedure, I hadn't done the dpkg-reconfigure step and the apt-get.  I went back and performed the steps.  In the dpkg-reconfigure step, I get the impression (from other stuff that I read trying to solve the problem) that the correct answer to the question is "Use dash as the default system shell" is "no".  Is this correct?

I tried performing these steps (answering "no") and then building again.  It gives the same error.

0 Kudos

195 Views
John_Kaz
NXP Employee
NXP Employee

Yes, I do believe you answered it correctly. According to the documentation "For Ubuntu and Debian hosts (reconfigure /bin/sh to point to bash):" so specifying "no" will default to bash. Also, I found a prior somewhat similar issue and apparently the problem was solved with the recommendation.

Here was the error:

source ./fsl-setup-poky -m p1022ds -j 2 -t 2

Build Configuration:

BB_VERSION = "1.18.0"

BUILD_SYS = "i686-linux"

NATIVELSBSTRING = "Ubuntu-10.04"

TARGET_SYS = "powerpc-fsl_networking-linux-gnuspe"

MACHINE = "p1022ds"

DISTRO = "fsl-networking"

DISTRO_VERSION = "1.4"

TUNE_FEATURES = "m32 spe ppce500v2"

TARGET_FPU = "ppc-efd"

meta 

meta-yocto 

meta-yocto-bsp = "sdk-v1.4.x:5a7532143a49f59a5c85b08d3daf574fb1eccd8d"

meta-fsl-ppc = "sdk-v1.4.x:f9fd0a617eb6913f87335c551918315ff4ebe18c"

meta-fsl-ppc-toolchain = "sdk-

v1.4.x:8ec94cec04527cb971c125b1ddd2c5375034d723"

meta-virtualization = "sdk-v1.4.x:ad6df4f59cd7646f61db29e8fa51f878329d6f93"

meta-fsl-networking = "

(detachedfrom00f7a53):00f7a535029ca7ef8c96ba8e9916d4742166bab0"

meta-oe 

meta-networking = "sdk-v1.4.x:7c8dd8f096b64a709175d37a08a4fb02ca263616"

NOTE: Resolving any missing task queue dependencies

NOTE: Preparing runqueue

NOTE: Executing SetScene Tasks

NOTE: Executing RunQueue Tasks

ERROR: Function failed: do_configure (see /home/wiwi/QorIQ-SDK-V1.4-

20130625-yocto/build_p1022ds_release/tmp/work/ppce500v2-fsl_networking-linux-

gnuspe/busybox/1.20.2-r9+fsl_networking/temp/log.do_configure.4933 for further

information)

ERROR: Logfile of failure stored in: /home/wiwi/QorIQ-SDK-V1.4-20130625-

yocto/build_p1022ds_release/tmp/work/ppce500v2-fsl_networking-linux-

gnuspe/busybox/1.20.2-r9+fsl_networking/temp/log.do_configure.4933

Log data follows:

| DEBUG: Executing python function sysroot_cleansstate

| DEBUG: Python function sysroot_cleansstate finished

| DEBUG: Executing shell function do_configure

| trap: 80: SIGHUP: bad trap

| ERROR: Function failed: do_configure (see /home/wiwi/QorIQ-SDK-V1.4-

20130625-yocto/build_p1022ds_release/tmp/work/ppce500v2-fsl_networking-linux-

gnuspe/busybox/1.20.2-r9+fsl_networking/temp/log.do_configure.4933 for further

information)

Here was the workaround:

This problem comes from Dash shell, you need to reconfigure the terminal and use "bash" instead, type the following command in the console.

$sudo dpkg-reconfigure dash

Choose the answer "No"

Close and launch your terminal.

In addition, please download and install both "Source" and "e500v2 Cache Binary" ISOs, the "Cache" ISO contains build binary cache, is used to accelerate the building, no need to build packages from the scratch.


0 Kudos

195 Views
andreb
Contributor I

Thanks for the tip about the source + cache.  I did do that too before coming across this error.

0 Kudos

195 Views
John_Kaz
NXP Employee
NXP Employee

Have you entered a Service Request for this issue?

0 Kudos

195 Views
andreb
Contributor I

Thanks John, I submitted one this morning.  Number 1-1155072671.

0 Kudos