Problem building with QorIQ-SDK-V1.8-20150619-yocto

cancel
Showing results for 
Search instead for 
Did you mean: 

Problem building with QorIQ-SDK-V1.8-20150619-yocto

636 Views
bruceboettjer
Contributor II

I downloaded the virtual box for QorIQ-SDK-V1.8-20150619-yocto

I have not installed anything in addition to what comes with the downloaded virtual image.

I have logged into the virtual box (Not as root) and run:

     source ./poky/fsl-setup-poky -m p4080ds

from: :~/SDK/QorIQ-SDK-V1.8-20150619-yocto

I observed that directory "build_p4080ds_release" was created.

if I cd to that directory and run:

     source SOURCE_THIS

and

     bitbake fsl-image-minimal

... I get the following error:

$ bitbake fsl-image-minimal

ERROR: Traceback (most recent call last):

  File "/home/freescale/SDK/QorIQ-SDK-V1.8-20150619-yocto/poky/bitbake/lib/bb/cookerdata.py", line 163, in wrapped

    return func(fn, *args)

  File "/home/freescale/SDK/QorIQ-SDK-V1.8-20150619-yocto/poky/bitbake/lib/bb/cookerdata.py", line 173, in parse_config_file

    return bb.parse.handle(fn, data, include)

  File "/home/freescale/SDK/QorIQ-SDK-V1.8-20150619-yocto/poky/bitbake/lib/bb/parse/__init__.py", line 99, in handle

    return h['handle'](fn, data, include)

  File "/home/freescale/SDK/QorIQ-SDK-V1.8-20150619-yocto/poky/bitbake/lib/bb/parse/parse_py/ConfHandler.py", line 151, in handle

    statements.eval(data)

  File "/home/freescale/SDK/QorIQ-SDK-V1.8-20150619-yocto/poky/bitbake/lib/bb/parse/ast.py", line 39, in eval

    statement.eval(data)

  File "/home/freescale/SDK/QorIQ-SDK-V1.8-20150619-yocto/poky/bitbake/lib/bb/parse/ast.py", line 63, in eval

    bb.parse.ConfHandler.include(self.filename, s, self.lineno, data, False)

  File "/home/freescale/SDK/QorIQ-SDK-V1.8-20150619-yocto/poky/bitbake/lib/bb/parse/parse_py/ConfHandler.py", line 97, in include

    ret = handle(fn, data, True)

  File "/home/freescale/SDK/QorIQ-SDK-V1.8-20150619-yocto/poky/bitbake/lib/bb/parse/__init__.py", line 99, in handle

    return h['handle'](fn, data, include)

  File "/home/freescale/SDK/QorIQ-SDK-V1.8-20150619-yocto/poky/bitbake/lib/bb/parse/parse_py/ConfHandler.py", line 147, in handle

    feeder(lineno, s, abs_fn, statements)

  File "/home/freescale/SDK/QorIQ-SDK-V1.8-20150619-yocto/poky/bitbake/lib/bb/parse/parse_py/ConfHandler.py", line 184, in feeder

    raise ParseError("unparsed line: '%s'" % s, fn, lineno);

ParseError: ParseError at /home/freescale/SDK/QorIQ-SDK-V1.8-20150619-yocto/meta-fsl-ppc/conf/machine/p4080ds.conf:1: unparsed line: '#@TYPE: Machine'

ERROR: Unable to parse conf/bitbake.conf: ParseError at /home/freescale/SDK/QorIQ-SDK-V1.8-20150619-yocto/meta-fsl-ppc/conf/machine/p4080ds.conf:1: unparsed line: '#@TYPE: Machine'

freescale@freescale-sdk:~/SDK/QorIQ-SDK-V1.8-20150619-yocto/build_p4080ds_release$

...I am confused.  The script finds the proper file (p4080ds.conf) but fails to notice that the first line is commented (?) - or am I supposed to change that line with

UBOOT_MACHINES ?= "P4080DS"

(Which appears further down the script)???

b

Labels (1)
Tags (3)
0 Kudos
4 Replies

157 Views
Pavel
NXP TechSupport
NXP TechSupport

Look at attached file.

Use recommended command sequence for VirtualBox using for the QorIQ SDK.


Have a great day,
Pavel

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

157 Views
bruceboettjer
Contributor II

Hello,

...Yes, I saw the VM User manual and followed everything religiously.

There is nothing in there that affects this issue.

The VM was installed correctly with the recommended version of Oracle VM Virtual Box (4.3.28)

(And extensions)

The instructions in "QorIQ SDK v1.8 Info Center.pdf" were also followed verbatim.

According to this documentation, I prepared the host environment (page 170) correctly.

I followed all of the instruction up to page 170 (builds)..

where I tried to build a fsl-image-minimal... witht he result posted above....

The bitbake scripts find the p4080ds.conf file, but fail to parser it correctly.

I followed the instructions... It appears that the default virtual image provided does no work.

Please help.

VR,

Bruce

0 Kudos

157 Views
Pavel
NXP TechSupport
NXP TechSupport

Look at attached file. Do you use similar command sequence?


Have a great day,
Pavel

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

157 Views
bruceboettjer
Contributor II

Hello,

I deleted the entire virtual machine and started again (from the same compressed image)

Using the same commands (I copy/pasted them from the same list as the first time)

I am now able to compile correctly and create images.

Thank you for the help.  I do not understand what was special about a second install, or what may have been done incorrectly the first time - I'm just glad the images are compiling.

Thank You.

Bruce

0 Kudos