P2020 use Yocto SDK 1.8 Rapidio char driver Problem?

cancel
Showing results for 
Search instead for 
Did you mean: 

P2020 use Yocto SDK 1.8 Rapidio char driver Problem?

220 Views
Contributor III

Can anybody answer ? 
Which SDK Version support the rmu module drive for rapidio of P2020。

just like this https://processors.wiki.ti.com/index.php/Linux_Core_RapidIO_User's_Guide described。

and I use SDK 1.8 and when i do as sdk doc I can not find /dev/rio_mportX, and all. 

Can anyone help me ! thanks very  much

khumphriP-SeriesyipingwangMandarjimtrudeau

Labels (1)
0 Kudos
3 Replies

80 Views
NXP TechSupport
NXP TechSupport

Use the following page for downloading SDK 2.7:

https://source.codeaurora.org/external/qoriq/qoriq-components/yocto-sdk/about/

Have a great day,
Pavel Chubakov

0 Kudos

80 Views
NXP TechSupport
NXP TechSupport

NXP offers Yocto SDK 2.7 for the P2020:

https://source.codeaurora.org/external/qoriq/qoriq-components/yocto-sdk/about/

 

Attached file contains Kconfig file from this SDK about rapidio.

See option about mport in this file.

Have a great day,
Pavel Chubakov

 

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

80 Views
Contributor III

I am sorry for my poor english,

first as i know yocto sdk of nxp last version is 2.0x?
and lsdk of nxp is not named as 2.x, so,what is the mean of sdk 2.7? and where can i download the version of sdk2.7?

0 Kudos