P1022 Custom board: No audio/sound

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

P1022 Custom board: No audio/sound

673 Views
ppc-fan
Contributor I

Hi All,

 

I bought a P1022 custom board, last year.

 

Technical details:

 

P1022, Version: 1.1

2 core e500v2 1.2GHz revision 5.1

4 GB DDR3 RAM

PCIe x4 with x16 connector

U-Boot 2014.04-00124-g2c02fcb (Sep 20 2014 - 11:36:22)

OS: Debian 7.8 PowerPC and Debian 8.0 PowerPCSPE

Kernel 3.8.13-rt9 and 3.18.5

Radeon HD5450 1GB DDR3 VRAM

 

I activated some codecs and the i2c debug output in the kernel config. Unfortunately Alsa didn't find any soundcards (see log file as attachment).

 

I also activated the following options in the kernel config:

 

# SoC Audio for Freescale CPUs

#

 

#

# Common SoC Audio options for Freescale CPUs:

#

# CONFIG_SND_SOC_FSL_ASRC is not set

# CONFIG_SND_SOC_FSL_SAI is not set

CONFIG_SND_SOC_FSL_SSI=y

# CONFIG_SND_SOC_FSL_SPDIF is not set

# CONFIG_SND_SOC_FSL_ESAI is not set

CONFIG_SND_SOC_FSL_UTILS=y

# CONFIG_SND_SOC_IMX_AUDMUX is not set

CONFIG_SND_POWERPC_SOC=y

CONFIG_SND_SOC_POWERPC_DMA=y

 

#

# SoC Audio support for Freescale PPC boards:

#

CONFIG_SND_SOC_P1022_DS=y

CONFIG_SND_SOC_I2C_AND_SPI=y

 

Do you have any tips for me, please?

 

Thanks in advance.

 

Cheers,

 

Christian

Original Attachment has been moved to: uImage-p1022-3.18.5-2-sound.log.zip

Labels (1)
0 Kudos
1 Reply

351 Views
sinanakman
Senior Contributor III

Hi Christian

What is the sound card really connected on this board ?

You will probably have to enable the codec support that represents

that card in your kernel config.

Also, your log is a grep i2c, I suggest you include the

full log so we can see if there was any problem with

ssi machine driver. BTW, you seemed to be using

an old kernel, I suggest you upgrade to a newer

mainline kernel (e.g. 3.19) which should have a better

support.

Regards

Sinan Akman

0 Kudos