Need advice to build a cross compil environnement for QorIQ e500 v2

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Need advice to build a cross compil environnement for QorIQ e500 v2

2,135 Views
latruffy
Contributor I

Hello,
sorry but I'm not a developer, and a newbie in compiling.

Here is my purpose :
I own an old Synology NAS DS213+ and would like to run Docker on it.
The syno package exists but not for my NAS model.
I've googled a lot to find its CPU is a Freescale P1022, QorIQ 2 cores 1,067GHz, then seemingly a e500 v2 core.
Then I'd like to cross compile Docker sources for my NAS, from my common Intel Linux latop (Ubuntu 20.04 LTS).

I've read a lot on this website, but I get alost about getting QorIQ Linux SDK, Layerscape SDK, what is Yocto, do I need CodeWarrior,...

Please could someone help me by advising the best and simplest way to get a cross compiling framework on my laptop to build e500 v2 binaries ? All solutions are accepted.

I surely plan to build this framework in a Linux Virtual Machine (Virtualbox), in order to avoid polluting my Ubuntu.

Thanks a lot by advance for any advice.

Labels (1)
0 Kudos
2 Replies

2,119 Views
yipingwang
NXP TechSupport
NXP TechSupport

Please download ISO "Image: QorIQ Linux SDK v2.0 PPCE500V2 IMAGE" from the following link 

https://www.nxp.com/design/software/embedded-software/linux-software-and-development-tools/linux-sdk...

Please mount this ISO and install Toolchian in folder fsl-toolchain.

Then set up the build environment.

$ source /opt/fsl-qoriq/2.0/environment-setup-ppce500v2-fsl-linux-gnuspe

0 Kudos

2,105 Views
latruffy
Contributor I

Thanks very much for your answer.
I built a VirtualBox VM based on Ubuntu 20.04.
And I've just ended to perform the SDK installation (downloaded according to your link above).

FYI, SDK files seems to be installed, but it ends with "relocate script" error (I don't know what it's concerned) :
latruffy@VBox:/media/latruffy/yocto/fsl-toolchain$ sudo ./fsl-qoriq-glibc-x86_64-ppce500v2-toolchain-2.0.sh
[sudo] ...
QorIQ SDK (FSL Reference Distro) SDK installer version 2.0
==========================================================
Enter target directory for SDK (default: /opt/fsl-qoriq/2.0):
The directory "/opt/fsl-qoriq/2.0" already contains a SDK for this architecture.
If you continue, existing files will be overwritten! Proceed[y/N]? y
Extracting SDK....................done
Setting it up.../usr/bin/env: «python»: Aucun fichier ou dossier de ce type
SDK could not be set up. Relocate script failed. Abort!

Since python3 is installed on my Ubuntu, I'm going to ignore this error.

Sourcing the build environment is OK :
latruffy@VBox:/media/latruffy/yocto/fsl-toolchain$ . /opt/fsl-qoriq/2.0/environment-setup-ppce500v2-fsl-linux-gnuspe
latruffy@VBox:/media/latruffy/yocto/fsl-toolchain$ echo $?
0
And "env" command shows lot of variables including /opt/fsl-qoriq/... path.

Now, as soon as I'll have time, I'll try to cross-compile Docker for my syno, using this SDK VM.
I'll keep informed if I'll ever succeed.

Thanks again for having helped.

0 Kudos