Can not find eth0 interface on T4240RDB board

cancel
Showing results for 
Search instead for 
Did you mean: 

Can not find eth0 interface on T4240RDB board

Jump to solution
1,321 Views
psun
Contributor II

Hello,

I am trying to set up the DHCP ethernet connection of my T4240RDB board. I am using the preinstalled linux image on board and connect to the console with the serial port.

After boot up, I used the ifconfig to check with the network interface, but there is only the "lo", but not eth0 or any other interface available. There is also no "dhclient" command available on board.

I connect the ethernet cable with the board to a switch using the ETH0 port. Here is the log for ifconfig:

root@t4240rdb:~# ifconfig  

lo        Link encap:Local Loopback 

          inet addr:127.0.0.1  Mask:255.0.0.0

          inet6 addr: ::1/128 Scope:Host

          UP LOOPBACK RUNNING  MTU:65536  Metric:1

          RX packets:16 errors:0 dropped:0 overruns:0 frame:0

          TX packets:16 errors:0 dropped:0 overruns:0 carrier:0

          collisions:0 txqueuelen:0

          RX bytes:1032 (1.0 KiB)  TX bytes:1032 (1.0 KiB)

 

I have also attached the u boot log for reference.

Thanks, have a great day!

 

Regards,

Peng

Original Attachment has been moved to: u_boot.log.zip

Labels (1)
Tags (2)
0 Kudos
1 Solution
362 Views
yipingwang
NXP TechSupport
NXP TechSupport

Hello Peng,

For T4240RDB, FMAN ucode address on the current bank is eff00000, you also could get this information from u-boot log.

From SDK 1.6 Know issue list, you could find the the following know issue.

Due to a board limitation, the T4240RDB does not support alternate bank capability which is typical for most boards.

For the coming SDK 1.7 release, booting from the alternate bank will be supported after updating CPLD, and u-boot source code is also updated, please refer to [U-Boot] powerpc/t4rdb: Add support of CPLD - Patchwork.


Have a great day,
Yiping

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

View solution in original post

0 Kudos
11 Replies
362 Views
yipingwang
NXP TechSupport
NXP TechSupport

Hello psun,

Please use "ifconfig -a" to show all the available network interfaces.

The package "dhcp" is not included into the default pre-built filesystem, please add "dhcp" into the variable IMAGE_INSTALL in meta-fsl-networking/images/fsl-image-core.bb and rebuild the filesystem.

There is a document QorIQ Linux SDK 1.6 Working With Yocto about how to use Yocto with Linux SDK,

you could take a look if needed.

Have a great day,
Yiping

-------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-------------------------------------------------------------------------------

362 Views
psun
Contributor II

Hello Yiping,

Thanks so much for your reply.

Here is the output of ifconfig -a:

root@t4240rdb:~# ifconfig -a

eth0      Link encap:Ethernet  HWaddr 00:11:22:33:44:66 

          BROADCAST MULTICAST  MTU:1500  Metric:1

          RX packets:0 errors:0 dropped:0 overruns:0 frame:0

          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

          collisions:0 txqueuelen:1000

          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback 

          inet addr:127.0.0.1  Mask:255.0.0.0

          inet6 addr: ::1/128 Scope:Host

          UP LOOPBACK RUNNING  MTU:65536  Metric:1

          RX packets:0 errors:0 dropped:0 overruns:0 frame:0

          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

          collisions:0 txqueuelen:0

          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

sit0      Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-10-10-00-00-00-00-00-00-00-00 

          NOARP  MTU:1480  Metric:1

          RX packets:0 errors:0 dropped:0 overruns:0 frame:0

          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

          collisions:0 txqueuelen:0

          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

tunl0     Link encap:IPIP Tunnel  HWaddr  

          NOARP  MTU:0  Metric:1

          RX packets:0 errors:0 dropped:0 overruns:0 frame:0

          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

          collisions:0 txqueuelen:0

          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

The mac address of the eth0 should be 00:10:F3:3A:B7:76 as I see in u boot. And I can use DHCP to obtain correct IP address and load file via TFTP in u boot. But I can not find this network interface once in linux. I am very confused.

And the bitbake was failed after adding "dhcp" option.

Thanks for any advices!

Have a great day!

Regards,

Peng

0 Kudos
362 Views
yipingwang
NXP TechSupport
NXP TechSupport

Hello Peng,

Please provide u-boot environment with "pri" command and Kernel boot log.

I didn't find problem to build dhcp.

Please also provide your bitbake build log with attachment.


Have a great day,
Yiping

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

362 Views
psun
Contributor II

Hello Yiping,

Please find attached file for the u boot log and the kernel boot log.

I am trying to repeat the process of build the core image with dhcp package, will let you know the log later.

The networking interface problem itself is not related to the DHCP, right?

Thanks so much for your reply, have a great day!

Regards,

Peng

0 Kudos
362 Views
yipingwang
NXP TechSupport
NXP TechSupport

Hello Peng,

The root cause is that you are using the dtb file for usdpaa, after the system boots up, all the DPAA Ethernet ports have already been assigned to USDPAA, so you cannot see them in Linux.

Please use the normal dtb file uImage-t4240rdb.dtb, and the DPAA Ethernet port in Linux should be named like fm1-gb0.

I didn't find problem to add "dhcp" and build core image, if your problem remains, please provide your error log.


Have a great day,
Yiping

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos
362 Views
psun
Contributor II

Hello Yiping,

The reason I use the dtb for usdapp is because if I use the dtb file uImage-t4240.dtb it will cause error while booting. I have provided the log for the error attached.

If use uImage-t4240rdb-usdpaa-shared-interfaces.dtb, the system could boot up but still shown the same ethernet interface as using uImage-t4240rdb-usdpaa.dtb.

Thanks very much for your help, I appreciate it!

Regards,

Peng

0 Kudos
362 Views
yipingwang
NXP TechSupport
NXP TechSupport

Hello Peng,

Please also update u-boot to SDK 1.6, I checked SDK 1.5 ISO, it seems that SDK 1.5 doesn't support T4240RDB.

And please also use RCW for T4240 Rev 2, according to your log, there is a warning about SERDES clock configuration.

I believe this error should be caused by incompatible software.

If your problem remains, please feel free to let me know.


Have a great day,
Yiping

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos
362 Views
psun
Contributor II

Hello Yiping,

It works at one time, but once reset, I lost the ethernet. I figured out the problem is because the u-boot version is still 1.5, thus I tried to update the u-boot to 1.6. I got it updated finally, but it seems the system could not find the ucode or fman. I have attached the log for both the uboot and the printenv.

I know I might need to re-install the ucode. But followed the doc online at Freescale Technical Information Center, it advice me to flash it to the address of ebf00000, which I tried but make effect at all. This is an alternative bank address, should I try to flash the ucode to its original bank? I could not find the original bank address anywhere online, can you point me to this information?

In addition, the following way to alternative banks seems does not work for the T4240RDB board:

Bank switching can be done in U-Boot using the following statements:

  • Switch to bank 0: reset
  • Switch to alternate bank: pix altbank (for P2041RDB: cpld reset altbank, for T4240QDS,B4860/B4420QDS: qix altbank)

Do you know how could I switch to the alternative bank on T4240RDB board?

Thanks very much for your help, I appreciate it!

0 Kudos
363 Views
yipingwang
NXP TechSupport
NXP TechSupport

Hello Peng,

For T4240RDB, FMAN ucode address on the current bank is eff00000, you also could get this information from u-boot log.

From SDK 1.6 Know issue list, you could find the the following know issue.

Due to a board limitation, the T4240RDB does not support alternate bank capability which is typical for most boards.

For the coming SDK 1.7 release, booting from the alternate bank will be supported after updating CPLD, and u-boot source code is also updated, please refer to [U-Boot] powerpc/t4rdb: Add support of CPLD - Patchwork.


Have a great day,
Yiping

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

View solution in original post

0 Kudos
362 Views
psun
Contributor II

Hello Yiping,

Thanks so much, it finally works with the NFS file system after updating the ucode on the address.

I appreciate your kind help for all these issues!

Best Regards,

Peng

0 Kudos
362 Views
psun
Contributor II

Hello Yiping,

The problem has been solved. As you suggested, I updated the RCW file for the board. Then I could find the ethernet interfaces successfully!

Thank you so much for your kind help for this issue, I appreciate it a lot!

Best Regards,

Peng

0 Kudos