ltib for MPC8313E RDB fails on ubuntu 9.10

cancel
Showing results for 
Search instead for 
Did you mean: 

ltib for MPC8313E RDB fails on ubuntu 9.10

1,104 Views
dexkid
Contributor I

Hi guys,

 

ltib for MPC8318E RDB is failing on my Ubuntu 9.10.

 

 

vishal@shrek:~/Freescale/ltib-mpc8313erdb-20081222$ ./ltib -c+ [ -n  -a ! -f config/platform/mpc8313erdb/.config ]+ [ -n  ]+ cd config/platform/mpc8313erdb+ mconf main.lkcsh: mconf: not foundDied at ./ltib line 2689.traceback: main::ltib_config:2689  main::pre_build_checks:1288   main:495Started: Sun Feb 20 22:36:17 2011Ended:   Sun Feb 20 22:36:17 2011Elapsed: 0 secondsBuild FailedExiting on error or interruptvishal@shrek:~/Freescale/ltib-mpc8313erdb-20081222$

 

The error part of the host_config.log is as follows

 

 

Executing(--clean): /bin/sh -e /home/vishal/Freescale/ltib-mpc8313erdb-20081222/tmp/rpm-tmp.N9pRXE+ umask 022+ cd /tmp/rpm-vishal/BUILD+ rm -rf rpm-4.0.4+ exit 0Build time for rpm-fs: 157 secondserror: cannot open Name index using db3 - No such file or directory (2)error: cannot open Name index using db3 - No such file or directory (2)sudo rpm --root / --dbpath /tmp/rpm-vishal/rpmdb -e --allmatches --nodeps --define '_tmppath /home/vishal/Freescale/ltib-mpc8313erdb-20081222/tmp' rpm-fs 2>/dev/nullsudo rpm --root / --dbpath /tmp/rpm-vishal/rpmdb --ignorearch -ivh --force --nodeps --excludedocs --define '_tmppath /home/vishal/Freescale/ltib-mpc8313erdb-20081222/tmp' /tmp/rpm-vishal/RPMS/i686/rpm-fs-4.0.4-1.i686.rpmrpm: please use alien to install rpm packages on Debian, if you are really sure use --force-debian switch. See README.Debian for more details.sudo /opt/freescale/ltib/usr/bin/rpm --root / --dbpath /opt/freescale/ltib/var/lib/rpm -Uv --justdb --notriggers --noscripts --nodeps /tmp/rpm-vishal/RPMS/i686/rpm-fs-4.0.4-1.i686.rpmsudo: /opt/freescale/ltib/usr/bin/rpm: command not foundProcessing platform: Host support packages============================================using /home/vishal/Freescale/ltib-mpc8313erdb-20081222/config/platform/host/ltib.preconfigProcessing: fake-provides===========================Build path taken because: no prebuilt rpm, 

 I have attached the host_config logfile.

 

Please suggest what package do I need to install / remove to get ltib installed.

 

 

 

 

0 Kudos
6 Replies

210 Views
Habitant
NXP TechSupport
NXP TechSupport

Can you try (K)Ubuntu 8.04? Linux BSP for MPC8313E is proven to work on this KUbuntu version, and we don't officially support Ubuntu 9.x and higher.

 

By the way, you can create a formal service request to our support team on https://www.freescale.com/webapp/servicerequest.create_SR.framework for LTIB issues. You can get faster response from them. 

 

0 Kudos

210 Views
dexkid
Contributor I

Hi Habitant,

 

I was able to get LTIB compiled on Ubuntu 9.04.

 

Thanks for giving the link to the support team.

 

 

0 Kudos

210 Views
srilakshmikanag
Contributor I

Hi Vishal,

Can you share with me how you have resolved this mconf error?

At present I am facing same error with my ubuntu 9 version.

Error :-

Can't exec "mconf": No such file or directory at /u/users/srilak/L3.0.35_12.09.01_GA_source/ltib_cvs_latest/bin/Ltibutils.pm line 1011.

exec: mconf /u/users/srilak/L3.0.35_12.09.01_GA_source/ltib_cvs_latest/config/main.lkc: No such file or directory at /u/users/srilak/L3.0.35_12.09.01_GA_source/ltib_cvs_latest/bin/Ltibutils.pm line 1011.

Regards,

Srilakshmi

0 Kudos

210 Views
Brodek
Contributor II

I've the same problem on ubuntu 10.10

 

It's 3 days that I try to solve it but for all my tentatives are failed.

0 Kudos

210 Views
dexkid
Contributor I

Hi Brodek,

 

Any luck finally with running it on Ubuntu 10.10 ?

 

0 Kudos

210 Views
Vasanthragavend
Contributor II

are u still facing the problem or is it solved? it says sudo command not found! have u installed sudo in ur linux?

0 Kudos