gstreamer video/x-vp6-flash not working in Freescale Ubuntu

cancel
Showing results for 
Search instead for 
Did you mean: 

gstreamer video/x-vp6-flash not working in Freescale Ubuntu

Jump to solution
766 Views
heikkiti
Contributor II

Hi

I have Sabre Lite board with Freescale L3.0.35_1.1.0_oneiric Ubuntu. Gstreamer does not play .flv file with video/x-vp6-flash type content but does not give any error either:

linaro@linaro-ubuntu-desktop:~$ gst-launch playbin2 uri="file://$PWD/6649253.flv"

Setting pipeline to PAUSED ...

Pipeline is PREROLLING ...

Aiur: 3.0.5

Core: BLN_MAD-MMLAYER_FLVPARSER_ARM11_01.08.08  build on Dec 10 2012 15:43:34

  mime: video/x-flv

  file: /usr/lib/imx-mm/parser/lib_flv_parser_arm11_elinux.so.3.1

Content Info:

    URI:

          file:///home/linaro/6649253.flv

    Idx File:

          /home/linaro/.aiur/.home.linaro.6649253.flv.aidx

    Seekable  : Yes

    Size(byte): 18275887

Movie Info:

    Seekable  : Yes

    Live      : No

    Duration  : 0:03:50.000000000

    ReadMode  : File

    Track     : 2

Track 00 [audio_000000] Enabled

    Duration: 0:03:50.000000000

    Language:

    Mime:

          audio/mpeg, mpegversion=(int)1, framed=(boolean)true, channels=(int)2, rate=(int

          )44100, bitrate=(int)0

Track 01 [video_000000] Enabled

    Duration: 0:03:50.000000000

    Language:

    Mime:

          video/x-vp6-flash, width=(int)504, height=(int)404, framerate=(fraction)30/1

MFW_GST_V4LSINK_PLUGIN 3.0.5 build on Dec 14 2012 13:58:00.

On my desktop Ubuntu the same file works. There is gstreamer0.10-ffmpeg package that as I understood has support for this type.

So I wonder what is the problem. Any suggestions?

1 Solution
62 Views
heikkiti
Contributor II

Hi

I succeeded to play vp6-flash video by constructing pipeline manually like this:

gst-launch filesrc location="6649253.flv" ! flvdemux name=mux mux.video ! queue ! ffdec_vp6f ! ffmpegcolorspace ! mfw_v4lsink

I think playbin2 tries to use hardware coded that cannot handle this content. Is it bug in coded or playbin then?

But I cannot play audio of the file:

linaro@linaro-ubuntu-desktop:~$ gst-launch filesrc location="6649253.flv" ! flvdemux name=mux mux.audio ! mpegaudioparse ! flump3dec ! audioconvert ! alsasink

Setting pipeline to PAUSED ...

Pipeline is PREROLLING ...

ERROR: from element /GstPipeline:pipeline0/GstFlvDemux:mux: Internal data stream error.

Additional debug info:

gstflvdemux.c(2388): gst_flv_demux_loop (): /GstPipeline:pipeline0/GstFlvDemux:mux:

stream stopped, reason not-linked

ERROR: pipeline doesn't want to preroll.

Setting pipeline to NULL ...

Freeing pipeline ...

Same command with same file works on my desktop ubuntu. Otherwise I am able to play mp3 in the board:
gst-launch filesrc location="file.mp3" ! mpegaudioparse ! flump3dec ! audioconvert ! alsasink

As if there is something wrong in Freescale L3.0.35_1.1.0_oneiric's gstreamer setup.

View solution in original post

1 Reply
63 Views
heikkiti
Contributor II

Hi

I succeeded to play vp6-flash video by constructing pipeline manually like this:

gst-launch filesrc location="6649253.flv" ! flvdemux name=mux mux.video ! queue ! ffdec_vp6f ! ffmpegcolorspace ! mfw_v4lsink

I think playbin2 tries to use hardware coded that cannot handle this content. Is it bug in coded or playbin then?

But I cannot play audio of the file:

linaro@linaro-ubuntu-desktop:~$ gst-launch filesrc location="6649253.flv" ! flvdemux name=mux mux.audio ! mpegaudioparse ! flump3dec ! audioconvert ! alsasink

Setting pipeline to PAUSED ...

Pipeline is PREROLLING ...

ERROR: from element /GstPipeline:pipeline0/GstFlvDemux:mux: Internal data stream error.

Additional debug info:

gstflvdemux.c(2388): gst_flv_demux_loop (): /GstPipeline:pipeline0/GstFlvDemux:mux:

stream stopped, reason not-linked

ERROR: pipeline doesn't want to preroll.

Setting pipeline to NULL ...

Freeing pipeline ...

Same command with same file works on my desktop ubuntu. Otherwise I am able to play mp3 in the board:
gst-launch filesrc location="file.mp3" ! mpegaudioparse ! flump3dec ! audioconvert ! alsasink

As if there is something wrong in Freescale L3.0.35_1.1.0_oneiric's gstreamer setup.

View solution in original post