What causes this problem and how to solve it?

cancel
Showing results for 
Search instead for 
Did you mean: 

What causes this problem and how to solve it?

199 Views
benjamin_bodnar
Contributor I

Hi,

I have an MKL16Z256VH4 uC, and I would like to use the LPTMR to wake up the device from VLPS sleep mode in every millisecundum. With this timer I set a LED to blink or not for a given time. This worked fine but I wanted some optimization to consume less current.

I tried to run my code, but the led blinked only if the code ran with debugger, or if I attached the RTT Viewer to the uC.

Why does my code run correctly only with RTT viewer?

0 Kudos
1 Reply

147 Views
kerryzhou
NXP TechSupport
NXP TechSupport

Hi Benjamin Bodnár,

   Do you make the code enter the VLPS mode when you write the led blinky code in the LPTMR?

   If your chip is in the VLPS mode, the debug is not correct, please check this information from the reference manual:

pastedImage_1.png

So, I think you can test your code like this method, don't enter the low power mode, then use the LPTMR to blink your LED, just download the code to your chip, and test it.

  Whether your problem still exist?

Any updated information from your side, please kindly let me know.


Have a great day,
Kerry

-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

0 Kudos