RedLink fails with MCU-Link Firmware 3.108

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

RedLink fails with MCU-Link Firmware 3.108

1,048 Views
Bjoggi308
Contributor I

My RedLink scripts to program my LPC546xx devices are failing after switching to MCUXpresso 11.7.0 and updating my MCU-Link firmware to 3.108

My system is Windows 10 running MSYS2.

with MCU-Link 2.263 I successfully run this command: 

"${NXPREDLINK}" --debug 4 -pGeneric-M4 --CoreIndex=0 --flash-load "${OUT_MCU_FLASH_BIN_FILE}" -g --region-clear --region INTERNAL:0x0,0x80000,LPC5460x_512K.cfx --load-base 0x0 || { echo "ERROR: PROGRAMMING TARGET MCU FLASH"; exit -1; }
 
But it fails with MCU-Link 3.108 Firmware like this:

Ns: MCUXpresso IDE RedlinkMulti Driver v11.7 (Jan 12 2023 18:05:45 - crt_emu_cm_redlink.exe build 1)
Pc: ( 0) Reading remote configuration
Wc(03). No cache support.
Nc: Found part description in XML file CM4.xml
Pc: ( 5) Remote configuration complete
Nc: Restarted LinkServer process (PID 11696).
Ns: redlink server client - failed to receive response (to op 26) from server after 2000ms - timed out (rc 138)
Ns: redlink server client - warning - 28 bytes of unexpected data from the server
Nc: Probe Firmware: MCU-LINK (r0FF) CMSIS-DAP V3.108 (NXP Semiconductors)
Nc: Serial Number: CEHK2DDVACTLC
Nc: VID:PID: 1FC9:0143
Nc: USB Path: 0001:001a:00
Nc: probe 1 TAP 0 failed to read TAP ID - Ee(AE). Redlink interface error 174.
Nc: connection failed - Ee(AE). Redlink interface error 174... Retrying
Nc: probe 1 TAP 0 failed to read TAP ID - Ee(AE). Redlink interface error 174.
Ed:02: Failed on connect: Ee(AE). Redlink interface error 174.
Et: Probe(0): Connected&Reset. Was: NotConnected. DpID: 00000000. CpuID: 00000000. Info: <None>
Nc: Last stub error 0: OK
Nc: Last sticky error: 0x0 AIndex: 0
Nc: No debug bus (MemAp) selected
Nc: DAP Speed test unexecuted or failed
Nc: Debug protocol: SWD. RTCK: Disabled. Vector catch: Disabled.
Pc: (100) Target Connection Failed

Any ideas ? 
Tags (1)
0 Kudos
6 Replies

872 Views
AndreVB
Contributor III

Hello NXP team,

I just have a similar problem with two KL17 parts in two boards. Boards worked for +1 year ago. After install MCUXpresso IDE v11.6.1 MCUlink  firmware MCU-Link 2.263 I had this problem.

Now I updated MCUlink and MCUXpresso to latest versions, but I can't reconnect with the boards.  Try to resurrect them but no success. Try with PEmicro but no use too. Any suggestions? 

Thank you

0 Kudos

1,036 Views
Bjoggi308
Contributor I

Lucas, I did notice that MCUX 11.7.0 works with the older MCU-Link Firmware, although it prompts for an update.. 

For now I'll just stick with MCU-Link V2.263 until this is fixed. 

0 Kudos

1,037 Views
lucas_cao
NXP Employee
NXP Employee

Hi 

I met a samiliar issue before.

My way is using the latest MCUX and the issue gone.

Not sure it can help you but maybe you can try it.

0 Kudos

975 Views
Bjoggi308
Contributor I

I am using the Redlink from MCUX 11.7.0 so this should work. This needs to be fixed as I can't update any of my teams numerous MCU-Link boards beyond V2.263 and I'd really like to take advantage of the faster 3.108 USB connection. 

We have dozens of scripts that use RedLink for chip erasure and programing among other things. 

0 Kudos

959 Views
RaRo
NXP TechSupport
NXP TechSupport

Hello @Bjoggi308,

We are letting the people in charge to know about this for future updates. Meanwhile, could you please try with an LPC546xx SDK v2.13 MCUXpresso IDE example? Is the same behavior happening?

Also, for double check, could you please check if you placed correctly the jumper J3 before updating the MCU-Link? Getting Started with the MCU-Link | NXP Semiconductors

Best regards, Raul.

0 Kudos

957 Views
Bjoggi308
Contributor I

MCUX IDE 11.7.0 works fine with 3.108 MCU-Link. Debug/Start/Stop/Step/Etc.

Yes, I did remove the Jumper after Updating. 

Here is an example from executing Erase script with previous MCU-Link FW version (2.263):

Ns: MCUXpresso IDE RedlinkMulti Driver v11.7 (Jan 12 2023 18:05:45 - crt_emu_cm_redlink.exe build 1)
Pc: ( 0) Reading remote configuration
Wc(03). No cache support.
Nc: Found part description in XML file CM4.xml
Pc: ( 5) Remote configuration complete
Nc: Restarted LinkServer process (PID 34512).
Nc: Probe Firmware: MCU-LINK (r0FF) CMSIS-DAP V2.263 (NXP Semiconductors)
Nc: Serial Number: S2SIDYH35RIGB
Nc: VID:PID: 1FC9:0143
Nc: USB Path: \\?\hid#vid_1fc9&pid_0143&mi_00#9&3587e87b&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}
Nc: Using memory from core 0 after searching for a good core
Pc: ( 30) Emulator Connected
Pc: ( 40) Debug Halt
Pc: ( 50) CPU ID
Nc: debug interface type = CoreSight DP (DAP DP ID 2BA01477) over SWD TAP 0
Nc: processor type = Cortex-M4 (CPU ID 00000C24) on DAP AP 0
Nc: number of h/w breakpoints = 6
Nc: number of flash patches = 2
Nc: number of h/w watchpoints = 4
Nc: Probe(0): Connected&Reset. DpID: 2BA01477. CpuID: 00000C24. Info: <None>
Nc: Debug protocol: SWD. RTCK: Disabled. Vector catch: Disabled.
Ns: Content of CoreSight Debug ROM(s):
Nc: RBASE E00FF000: CID B105100D PID 04000BB4C4 ROM (type 0x1)
Nc: ROM 1 E000E000: CID B105E00D PID 04000BB00C Gen SCS (type 0x0)
Nc: ROM 1 E0001000: CID B105E00D PID 04003BB002 Gen DWT (type 0x0)
Nc: ROM 1 E0002000: CID B105E00D PID 04002BB003 Gen FPB (type 0x0)
Nc: ROM 1 E0000000: CID B105E00D PID 04003BB001 Gen ITM (type 0x0)
Nc: ROM 1 E0040000: CID B105900D PID 04000BB9A1 CSt TPIU type 0x11 Trace Sink - TPIU
Nc: ROM 1 E0041000: CID B105900D PID 04000BB925 CSt ETM type 0x13 Trace Source - Core
Nc: NXP: Generic-M4
Nc: DAP stride is 4096 bytes (1024 words)
Ns: Clearing flash regions defined outside command line
Nc: Inspected v.2 On-chip Flash Memory LPC5460x_512K.cfx
Nc: Image 'LPC5460x (512K Flash) Jan 13 2023 11:53:29'
Pc: ( 65) Chip Setup Complete
Nt: Connected: was_reset=true. was_stopped=false
Pc: ( 70) License Check Complete
Nc: Opening flash driver LPC5460x_512K.cfx
Nc: Sending VECTRESET to run flash driver
Nc: Flash device supported (512KB = 16*32K at 0x0)
Nt: Mass Erase flash at 0x0
Nc: Closing flash driver LPC5460x_512K.cfx
Nt: MassErase completed (in 117ms)

0 Kudos