No serial output whatsoever on 8MMINI

cancel
Showing results for 
Search instead for 
Did you mean: 

No serial output whatsoever on 8MMINI

123 Views
Contributor I

I just received an 8MMINI. There is no output on serial or HDMI whatsover, no matter which DIP settings I use.

Also, when I try to use uuu, I get the below. I see that /dev/ttyUSB{0,1} get created. Do I just have a dead board that needs to be RMA'ed?

root@rockpi:~# uuu ./L4.14.78_1.0.0_ga_images_MX8MMEVK.zip
uuu (Universal Update Utility) for nxp imx chips -- libuuu_1.4.69-1-gf1d41e2

Success 0 Failure 0 Wait for Known USB Device Appear...

Prep 1/ 0 [=================100%=================] Http Download\Uncompress

0 Kudos
20 Replies

109 Views
Contributor I

I can see the Red/Green on the HDMI board, as well as the red power light. I've tried the eMMC boot to android (this board is freshly out of box) and I get no serial or HDMI output. I've also switched the jumpers to download mode to use uuu, and I get the above. I'm going to go pick up an SD card. From what I gather, I need to dd the sdcard image and then set the jumpers to boot from it to see if that works. However, since it did not even boot android, I'm worried that my board is dead.

0 Kudos

99 Views
Contributor I

OK, so from the L4.14.78 image, I burned the .sdcard image to an sdcard, put it in the box, changed the jumpers to boot from uSD. Still nothing.

I've initiated an RMA with futurenet, but want to make sure it really doesn't work before I send it back.

0 Kudos

88 Views
NXP TechSupport
NXP TechSupport

Serial Port has been tested? Are you using windows Terminal? or Linux Terminal? do you get the Serial Driver detected?

 

0 Kudos

73 Views
Contributor I

I see /dev/ttyUSB* get created and the FTDI drivers get loaded under Linux, so this should work.

Also, again, no HDMI output either when booting from emmc

0 Kudos

62 Views
Contributor I

and when I boot from eMMC, no ethernet lights appear. I'm guessing that perhaps this board was never provisioned? Unfortunately, I have no JTAG to do further tests, so this probably has to be returned.

0 Kudos

53 Views
NXP TechSupport
NXP TechSupport

Can you please test using the latest version of Linux BSP  Linux 5.4.70 You can download the images to flash using the UUU tool from the following link:

https://www.nxp.com/webapp/Download?colCode=L5.4.70_2.3.0_MX8MM&appType=license

If this doesn´t work then go forward with the Return

 

0 Kudos

46 Views
Contributor I

Just to be clear on steps.

1) run "uuu <file.zip>"

2) Turn on board with jumpers set to "Download Mode"

 

correct?

0 Kudos

42 Views
NXP TechSupport
NXP TechSupport

Yes, that´s correct

 

0 Kudos

40 Views
Contributor I

Yeah, nothing happens. One more question. When it says "x" on the jumper guide, I assume that means it doesn't matter what it is set to?

root@rockpi:~# uuu /tmp/L5.4.70-2.3.0_images_MX8MMEVK.zip
uuu (Universal Update Utility) for nxp imx chips -- libuuu_1.4.69-1-gf1d41e2

Success 0 Failure 0 Wait for Known USB Device Appear...

Prep 1/ 0 [=================100%=================] Http Download\Uncompress

0 Kudos

38 Views
NXP TechSupport
NXP TechSupport

You can check if the board was detected from the Host PC,  with a

lsusb

 

0 Kudos

36 Views
Contributor I

I believe so:

Bus 005 Device 002: ID 0403:6010 Future Technology Devices International, Ltd FT2232C Dual USB-UART/FIFO IC

0 Kudos

33 Views
NXP TechSupport
NXP TechSupport

The board is Burn,  you need to start the return,  it was my last idea to have the USB cables wrong into the host or in the power, But this confirms that the board simply it is not working.

 

0 Kudos

22 Views
Contributor I

OK, so as I was packing it away, I noticed it shipped with an SD card. I plugged this in, and it works, however the console is on ttyUSB1 and not ttyUSB0 like the docs say.

So I'll try the other SD card I made, but I have another question. How do I load a dev environment (gcc and such) on this board as I need to build some drivers?

0 Kudos

19 Views
Contributor I

ALso, these instructions completely do not work:

Get Started with the MCIMX8M-EVK | NXP

There is no "mfgtools" file

0 Kudos

7 Views
Contributor I

Any update on how I would get a dev environment on this board so I can compile a driver?

0 Kudos

102 Views
NXP TechSupport
NXP TechSupport

Do you think you can share a picture of the board?, how do you get the board?  In order to see if a warranty it is needed,  the person or distributor that sold you the board should enter the warranty process.

 

https://www.nxp.com/support/sample-and-buy/buy-direct/returns-and-warranty-information:WTBUY_DTD_RET...

 

 

0 Kudos

100 Views
Contributor I

Here is the picture, but before I RMA it, I don't want to get another one and have it act the same way.nxp1.jpg

0 Kudos

119 Views
NXP TechSupport
NXP TechSupport

You can follow the instructions of the Getting Started Page, using a PreBuilt Image, here is the link:

https://www.nxp.com/document/guide/get-started-with-the-i-mx-8m-mini-evk:GS-iMX-8M-Mini-EVK

 

 

0 Kudos

115 Views
Contributor I

I followed those instructions, and they do not work.

0 Kudos

113 Views
NXP TechSupport
NXP TechSupport

How about the LED lights of the board are they ON, which ones? which version of Linux BSP are you using?  are you trying SD,  eMMC? 

Can you please more information to debug?

 

0 Kudos