CMSIS-DAP no longer working after CMPA is written (LPC55S28-EVK)

cancel
Showing results for 
Search instead for 
Did you mean: 

CMSIS-DAP no longer working after CMPA is written (LPC55S28-EVK)

85 Views
Contributor I

Hi,

I'm using LPC55S28-EVK for test on writing custom data to customer factory page using this function (ffr_cust_factory_page_write()) where seal argument is set to false. After doing so, attempts to re-flash the board no longer possible due to CMSIS-DAP error. Is there any way to restore this board?

0 Kudos
4 Replies

36 Views
Contributor I

Hello,

The board works well with Eclipse/GNU-based tools from NXP and other industry.The board also includes an on-board,CMSIS-DAP compatible debug probe, For more details, please visit our cancellation and returns page.LPC55S69-EVK - LPCXpresso55S69 Development Board mysainsburys.

0 Kudos

65 Views
Contributor I

Thanks for the reply. I set the board to ISP mode by connecting jumper at J10 and P1 and I also connect a serial port to P8. However, I have tried debug with ISP and also using elftosb-gui but nothing happen. No reply is seen from blhost. Is there any instruction on how to fix similar issue like this? 

Thanks

0 Kudos

79 Views
NXP TechSupport
NXP TechSupport

Hi

Try if you can debug with ISP mode. If not, refer AN12283 to use elftosu-gui to refresh CMPA. normally this can solve the problem.

Have a nice day

Jun Zhang

 

0 Kudos

44 Views
NXP TechSupport
NXP TechSupport

How did you use elftosb-gui refresh CMPA? Could you please send me video or screenshots?

Thanks,

Jun Zhang

0 Kudos