Adjust the device tree to put the ilitek-ili9881c display into operation with the MX8M Mini

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Adjust the device tree to put the ilitek-ili9881c display into operation with the MX8M Mini

430 Views
Ayoub1
Contributor I

to make the display read, have at the beginning of the file:

~/yocto-demo/build/tmp/work-shared/imx8mmlpddr4evk/kernel/source/arch/arm64/boot/dts/freescale/imx8mm-evk.dts

 

the two nodes pwm_bl and dsi are written:

// SPDX-License-Identifier: (GPL-2.0+ OR MIT)
/*
* Copyright 2019-2020 NXP
*/

/dts-v1/;

#include <dt-bindings/usb/pd.h>
#include "imx8mm-evk.dtsi"

/ {
    model = "FSL i.MX8MM EVK board";
    compatible = "fsl,imx8mm-evk", "fsl,imx8mm";

    #include <dt-bindings/gpio/gpio.h>
    pwm_bl: pwm-bl {
        pinctrl-names = "default";
        enable-gpios = <&gpio1 8 GPIO_ACTIVE_HIGH>; /* GPIO1, IO 08 */
        backlight-gpios = <&gpio1 1 GPIO_ACTIVE_LOW>; /* DSI_BL_PWM(GPIO1 IO 01) */
    };
   
    dsi {
        #address-cells = <1>;
        #size-cells = <0>;
        panel@0 {
            compatible = "bananapi,lhr050h41", "ilitek,ili9881c";
            reg = <0>;
            backlight = <&pwm_bl>;
        };
    };

I have already integrated the driver
I can compile with the "make dtbs" command, but the display doesn't work yet
I don't know exactly what it is?
Am I writing in the right file? in the right place?
whether configurations are missing?

Labels (1)
0 Kudos
5 Replies

390 Views
Chavira
NXP TechSupport
NXP TechSupport

Hi @Ayoub1!

Thank you for contacting NXP Support!

 

I do not have that display to test by my side but you can refer to the documentation of the driver.

 

https://github.com/nxp-imx/linux-imx/blob/ccf0a99701a701fb48a04e31ffe3f9d585a8374a/Documentation/dev...

 

You have to change the "dsi" for "&mipi_dsi", please check the example of the mipi_dsi node configuration taking as an example the device tree of the imx8mm.

 

https://github.com/nxp-imx/linux-imx/blob/lf-6.1.y/arch/arm64/boot/dts/freescale/imx8mm-evk.dtsi#L56...

 

Best Regards!

Chavira

0 Kudos

347 Views
Ayoub1
Contributor I

Hello Chavira,

Thank you for your reply.
I used the example on ilitek,ili9881c.yaml file:

#include <dt-bindings/gpio/gpio.h>
&mipi_dsi {
    status = "okay";

    #address-cells = <1>;
    #size-cells = <0>;
    panel@0 {
        compatible = "bananapi,lhr050h41", "ilitek,ili9881c";
        reg = <0>;
        power supply = <&reg_display>;
        enable-gpios = <&gpio1 8 GPIO_ACTIVE_HIGH>; /* GPIO1, IO 08 */
       backlight = <&pwm_bl>;
    };
};

I get the 2 errors:
Reference to non-existent node or label "reg_display"
Reference to non-existent node or label "pwm_bl"

In the second link you sent me, the file imx8mm-evk.dtsi looks different than what I have.
e.g. I don't have an &i2c2 node

Best Regards!
Ayoub

0 Kudos

316 Views
Chavira
NXP TechSupport
NXP TechSupport

Hi @Ayoub1 !
Thank you for contacting NXP Support!

The power supply property is optional according to your connections.

You can consult all the features available for these properties in the next link:

https://github.com/nxp-imx/linux-imx/blob/ccf0a99701a701fb48a04e31ffe3f9d585a8374a/Documentation/dev...


You can check the next post to see a possible answer to your problem.

https://community.nxp.com/t5/i-MX-Processors/Ilitek-ILI9881C-MIPI-LCD-Panel-not-work-on-i-MX93/m-p/1...

Best Regards!
Chavira

0 Kudos

285 Views
Ayoub1
Contributor I

Hello Chavira,
Thank you for your reply.
Maybe @wenxue_guo can help me further.

Hello Wenxue_gue,

I tested your posted code at the following link:
https://community.nxp.com/t5/i-MX-Processors/Ilitek-ILI9881C-MIPI-LCD-Panel-not-work-on-i-MX93/m-p/1...
I didn't know how to compile the following nodes and references:
1) the knot

&dphy {
    status = "okay";
};


2) the three references

        pinctrl-0 = <&pinctrl_gpio_backlight>;
        backlight = <&backlight>;
        remote-endpoint = <&panel_in>;


It would be nice if you could help me with this.
Best regards
Ayoub

0 Kudos

357 Views
memara
Contributor I

Hi Chavira,

I am facing the same issue with mipi display.
I don't understand the relation between the 2 links. I did the same as in the yaml example but the in 2nd link there is no driver or reg specified.

thanks

0 Kudos