USBDM usbdm_4.12.1.70-1-amd64.deb: Cannot start debug

cancel
Showing results for 
Search instead for 
Did you mean: 

USBDM usbdm_4.12.1.70-1-amd64.deb: Cannot start debug

971 Views
michaelheidinge
Contributor III

Hi,

it seems to me, that USBDM 4.12.1.70 for amd64 can program the target, but then one cannot click on the start button to start debugging. Could you fix this?

I highlighted red what i mean.

Board: Freedom MKL25

IDE: Kinetis Design Studio 3.0.0

USBDM: 4.12.70

OS: Ubuntu 12.04 (amd64)

Using Windows 7, KDS3.0 and oder USBDM has not the issue.

-Michael

0 Kudos
7 Replies

394 Views
pgo
Senior Contributor V

Hi John,

I had only tested using the plugin with Eclipse in MINT 18 which worked OK.

I can get the same error you do with KDS and the USBDM plugin and I have not been able to find a reason.

I have also tested using the GDB PEMicro Interface and it fails in the same fashion.

Using the USBDM GDB server + the GDB Hardware Debugging interface (Generic GDB) also fails in the same way.

Basically the Eclipse GUI is not connected correctly to the debug session -

This leads me to believe the problem is in KDS and later versions of Linux - but I can't see any other posts complaining so I don't know what's going on.

pastedImage_5.png

pastedImage_1.png

pastedImage_3.png

bye

Update - I believe I have found the problem.  The plugin install is triggering an update of other plugins but uses the wrong Eclipse repository.

This has been fixed on the files on the GIT repository.

I will update the DEB file on Sourceforge shortly but I recommend using the instructions posted on GIT-HUB instead.  These build the executables from source and helps avoid any issues with which compiler version and libraries are on the system.  There are significant differences on GCC in the recent revisions of Linux.

Rebuild from source using the instructions on GITHUB(bottom of this page):

Unfortunately, it is necessary to re-install KDS as the changes in other plugin versions have to be fixed.

Sorry for the stuffing around.

bye

0 Kudos

394 Views
pgo
Senior Contributor V

Hi Michael,

I have tested this version with Ubuntu 15.10 running in Virtual box under windows 8 and it worked OK.

pastedImage_0.png

  • Could you check that the firmware  is updated to the version include the USBDM installation

/usr/share/usbdm/FlashImages/MKxx ?

  • Also could you post an exported copy of the project so I can check if it is something specific to the project settings?
0 Kudos

394 Views
jpa
Contributor IV

Peter,

I'm getting the same reaction on Ubuntu 14.04 and 15.04, and I'm stuck.  The debugger programs the board, the debugger can step through the source code if I manually type "step" in the debugger window, but it doesn't synchronize to the source window or allow me to use the debugger buttons.  My current setup:

Ubuntu 15.04 (64 bit) (edit: 15.04 in a VirtualBox virtual machine running on an Ubuntu host)

KDS 3.2.0 (gcc 4.8.4 revision 213147) (with and without latest updates)

MK60DN512VMD (raw processor)

usbdm_4.12.1.70-1-amd64.deb

MK25... board running latest usbdm firmware

Again, no problems getting the ARM FLASH programmer to see my target and program the CPU flash.

Project settings export and GDB trace will be attached if I can figure out how....at the end, you'll see me trying to set the language to see if that fixed anything (it doesn't).   

Seems like I'm so close and yet so far.  

0 Kudos

394 Views
jpa
Contributor IV

A follow-up...noting that you tested under 15.10, I upgraded the virtual machine from 15.04 to 15.10.  At that point, MergeXML throws a segmentation fault while installing usbdm.  I started with a fresh 15.10 install, and get the same results.   Attaching output from install.

0 Kudos

394 Views
pgo
Senior Contributor V

Hi John,

I have done a complete rebuild using MINT 18.

I suggest you try either of the following options:

bye

0 Kudos

394 Views
jpa
Contributor IV

Peter,

Thanks for all the work you're doing on this.  Sadly, Mint18 and your latest -140 have me at the exact same spot as Ubuntu 15.04.

I created a USBDM project with clock setup, compile, run the debugger.  The debug buttons at the top are never enabled, and the main.c source window never scrolls to the opening line of main().  If I type "step" into the gdb console, the console output indicates that it took a step and shows me a source line in the console window, but never in the source window.  The green LED on the FRDM board being used for the debugger blinks at about a 1 sec rate.

Apologies in advance if I'm doing or forgetting to do something really stupid.  I've attached the trace again, if that's helpful.  Note the warning about a missing .gdbinit file, is that significant?  Seems like everything is working if I can only get KDS to process the data coming back from the GDB server.

John

0 Kudos

394 Views
michaelheidinge
Contributor III

The usbdm installation fails while installing. Could you check this?

USBDM install fails under KDS3.2 on Ubuntu 16.04

0 Kudos