USBDM failed to modify CW 10.2 (Ubuntu 18.04)

cancel
Showing results for 
Search instead for 
Did you mean: 

USBDM failed to modify CW 10.2 (Ubuntu 18.04)

263 Views
Contributor II

Hello

Linux Addict, I recently installed CW MCU 10.2 (the last linux version of CW_MCU) on my laptop : Ubuntu 18.04 – amd A10-9600, for 9S08 and CFV1 projects.

I succeded with the installation of CW 10.2, P&E multilink and OSBDM-JM60. Unfortunately, the latest version of USBDM (4.12.1.230) for Debian failed to install. It seems that this is an Eclipse bug :

Error messages:

Error reading signed content:/tmp/signatureFile840752684725137854.jar

Caused by: java.security.NoSuchAlgorithmException: An error occurred while processing the signatures for the file: /tmp/signatureFile840752684725137854.jar

The reason :

https://bugs.eclipse.org/bugs/show_bug.cgi?id=470466

https://bugs.eclipse.org/bugs/show_bug.cgi?id=378155

A plugin that is signed with the Java 1.7 jarsigner tool cannot be installed into Eclipse.  
In 1.7, the jarsigner tool uses the SHA256 algorithm, which doesn't appear to be supported by Eclipse.Could somebody help me to solve this issue ?Best regards Thierry
0 Kudos
1 Reply

109 Views
Contributor II

OK, now it works fine with  a quite old i386 version of USBDM (usbdm_4.10.6.240-1-i386). OSBDM-JM60 from P&E works fine too.

For those who want to try, after dowloading the debian archive , I attach my procedure

Regards

Thierry

0 Kudos