USBDM, FRDM-KL25Z, not detecting K60 or KE18F?

Showing results for 
Search instead for 
Did you mean: 

USBDM, FRDM-KL25Z, not detecting K60 or KE18F?

Contributor III

I've been using USBDM ( ?) with a FRDM-KL25Z board to work on K60 projects successfully.

Now I'm trying to bring up a KE18F board.

The board and software that I was using didn't seem to detect the processor correctly (said it was an MK10DX and wouldn't program the part), so I upgraded to and downloaded new firmware to the FRDM board using  Still no joy, and now it can't detect the chip.  Connected to the earlier K60 project, and the new software can't properly detect the K60 (it apparently thinks that processor is an MK20DX64M7).   Tried "OpenSDAv2_1_Power.bin" firmware (because the file seemed to match version 1, and I'm pretty sure I was using 2_1 before), but doesn't seem any better. 

The KE18F board is brand new, our design, so a layout problem is a definite possibility.

But then why doesn't the latest software work with the K60?  Is there a version that should work with the KE18F? firmware and ARM Flash Programmer (OpenSDAv2_1.bin, "USBDM ARM-SWD for OpenSDA2")

K60   detects chip

KE18F fails, "Reason: Target reset pin timeout (rise)" or "Failed to probe target"

There's a 10k pull-up to 3.3V, a reset module (same as K60) but - now - no cap to ground. ( firmware, "USBDM ARM-SWD for OpenSDAv1")

K60 says it's MK20DX64M7

KE18F says it's MK20DX64M7 (different result on a second attempt?) (OpenSDAv2_1_Power.bin firmware, "USBDM ARM-SWD for OpenSDAv2.1")

K60  says it's MK20DX64M7

KE18F says it's MK20DX64M7 (different result this time?)

0 Kudos
1 Reply

Contributor III

Updating...I built usbdm from the github 'master'...using 'master' (and firmware from 'master') the ARM Flash programmer completes the "Detect Chip" process for both boards, disables the Device Selection box showing "[No matching device]", but selects "Filter by chip ID" and says "D14A" for K60, and "0006" for K18F.  I'm thinking this is the correct chip id for the K60, and incorrect for the K18F ("D105" ?), but I'm really reaching.  If I either a) leave it at "0006" or b) uncheck 'Filter by chip ID' and try to program the K18F, it tells me "Selected target device does not agree with detected device. (Unable to read/confirm CHIP_ID)".

Just tried to verify/program/erase the K60, and I get varying results. The first time it seemed to verify, but after that, it wouldn't erase or program the device, displaying the same error message as above.  Reprogrammed the K60 (using the same firmware but 4.12.130 Flash Programmer), everything went fine, went back to 'master' and tried the verify again and this time it said the buffers didn't match.  


Edit: attaching log files from running the debug version.  I check the debug connection, and then check the chip id.  Note that even with manually editing the FlashProgrammer_ARM.cfg file to set the device to PK60N512, the software changes the device to MKE02Z16M2.  

0 Kudos