UM11310 ( MC33771C) Simulink TPL Connection

cancel
Showing results for 
Search instead for 
Did you mean: 

UM11310 ( MC33771C) Simulink TPL Connection

196 Views
MuhammedAhmet
Contributor II

Hi .

I have device RD33771CNTREVM (UM11310) . I'm working from simulink for this device. Since there is no MC33771C support in Simulink tools, I applied the special code adding method.

https://community.nxp.com/t5/NXP-Model-Based-Design-Tools/How-to-use-your-own-C-code-in-our-Toolbox-...

I want to establish a TPL connection.

I tried many times but still couldn't communicate with MC33771C.

I made the LSPI settings according to here. :

https://community.nxp.com/t5/NXP-Model-Based-Design-Tools/Battery-measurements-with-Simulink-on-UM11...

I don't think these settings are suitable for me. (bcc peripheries.h)

Where am I doing wrong. How should the settings be?

0 Kudos
2 Replies

67 Views
MuhammedAhmet
Contributor II

Hello @mariuslucianand 

 I added the drivers here to the project.

https://www.nxp.com/design/analog-expert-software-and-tools/sdk-analog-expert-drivers/embedded-sw-ba...   

Although it is defined, I get a warning like this (undefined.png)

My device RD33771CNTREVM . Is there a sample project with this device? ( for Simulink)

Best regards.

Muhammet 

 

0 Kudos

84 Views
mariuslucianand
NXP Employee
NXP Employee

Hello @MuhammedAhmet 

At first sight, it looks that you are on the right track. You have enabled two SPI instances and yes, you have to modify the bcc_peripheries for the driver to call the instances/ chip selects you use for the board.

More than that, the article How-to-use-your-own-C-code... is handling the MC3377xB which has a different driver and different settings than the ones for the MC3377xC. So you need to use also the driver from here: EMBEDDED-SW-MC33771C 

What setup are you using? the one from the UM11310?

Regards,

Marius