Simulink Development S32K14x

cancel
Showing results for 
Search instead for 
Did you mean: 

Simulink Development S32K14x

1,050 Views
lukaszadrapa
NXP TechSupport
NXP TechSupport

Hi team,

created on behalf of customer:

...The Matlab/Simulink toolbox would make it much easier for our development, however we are currently having issues and cannot even build any of the provided demos.

Upon trying to build the demo we are getting an error like the following;
Error evaluating 'InitFcn' callback of block_diagram 'extmode_s32k14x'.
Callback string is 'mbd_s32k14_consistency_checks(bdroot(gcs));'
Caused by:
Undefined function 'mbd_s32k14_consistency_checks' for input arguments of type 'char'.
Component:Simulink | Category:Block diagram error

Please let me know if you have any suggestions.

Thanks,

Lukas

0 Kudos
5 Replies

450 Views
constantinrazva
NXP Employee
NXP Employee

Hello lukaszadrapa‌,

I think that he's having a problem with his license and the full error is something like this (but with s32k instead of s12zvm):

pastedImage_1.png

You can take a look here (around 1'49'') - although this video is for an earlier version, the licensing part has not changed. He has to take the steps in the video to generate his license - which is free.

Kind regards,

Razvan.

0 Kudos

450 Views
fernando_barrio
Contributor III

This is not the same error, the cause given by Simulink is different.

0 Kudos

450 Views
constantinrazva
NXP Employee
NXP Employee

Hello fernando.barrios@uwaterloo.ca‌,

So there is nothing mentioned about the license in the error? And does it happen on all examples, or only on the external mode one?

Can you give me some information from your environment? Can you run

ver

command in the MATLAB interpreter and write here its output ? And can you attach the example you're having trouble running?

Kind regards,

Razvan.

0 Kudos

450 Views
fernando_barrio
Contributor III

Hi Constantin, 

I apologize for the late reply. I have tried the external mode example and UART Hello World, they both give me the same error. Nothing mentioned about a license error, although I am getting a different "Caused By" I will attach a screenshot for you.

When I run the ver command I get the following (I have tried with 2018b as well);

MATLAB Version: 9.4.0.813654 (R2018a)
MATLAB License Number: 188546
Operating System: Microsoft Windows 10 Education Version 10.0 (Build 14393)
Java Version: Java 1.8.0_144-b01 with Oracle Corporation Java HotSpot(TM) 64-Bit Server VM mixed mode
-----------------------------------------------------------------------------------------------------
MATLAB Version 9.4 (R2018a)
Simulink Version 9.1 (R2018a)
Aerospace Blockset Version 3.21 (R2018a)
Aerospace Toolbox Version 2.21 (R2018a)
Antenna Toolbox Version 3.1 (R2018a)
Bioinformatics Toolbox Version 4.10 (R2018a)
Communications System Toolbox Version 6.6 (R2018a)
Computer Vision System Toolbox Version 8.1 (R2018a)
Control System Toolbox Version 10.4 (R2018a)
Curve Fitting Toolbox Version 3.5.7 (R2018a)
DSP System Toolbox Version 9.6 (R2018a)
Data Acquisition Toolbox Version 3.13 (R2018a)
Database Toolbox Version 8.1 (R2018a)
Econometrics Toolbox Version 5.0 (R2018a)
Embedded Coder Version 7.0 (R2018a)
Financial Toolbox Version 5.11 (R2018a)
Fixed-Point Designer Version 6.1 (R2018a)
Fuzzy Logic Toolbox Version 2.3.1 (R2018a)
Global Optimization Toolbox Version 3.4.4 (R2018a)
HDL Coder Version 3.12 (R2018a)
Image Acquisition Toolbox Version 5.4 (R2018a)
Image Processing Toolbox Version 10.2 (R2018a)
Instrument Control Toolbox Version 3.13 (R2018a)
LTE System Toolbox Version 2.6 (R2018a)
MATLAB Coder Version 4.0 (R2018a)
MATLAB Compiler Version 6.6 (R2018a)
MATLAB Compiler SDK Version 6.5 (R2018a)
Mapping Toolbox Version 4.6 (R2018a)
Model Predictive Control Toolbox Version 6.1 (R2018a)
Model-Based Design Toolbox for S32K1xx Series Version 2018.R1 (R2016b-R2018a)
Neural Network Toolbox Version 11.1 (R2018a)
Optimization Toolbox Version 8.1 (R2018a)
Parallel Computing Toolbox Version 6.12 (R2018a)
Partial Differential Equation Toolbox Version 3.0 (R2018a)
Phased Array System Toolbox Version 3.6 (R2018a)
RF Blockset Version 7.0 (R2018a)
RF Toolbox Version 3.4 (R2018a)
Robotics System Toolbox Version 2.0 (R2018a)
Robust Control Toolbox Version 6.4.1 (R2018a)
Signal Processing Toolbox Version 8.0 (R2018a)
SimBiology Version 5.8 (R2018a)
SimEvents Version 5.4 (R2018a)
Simscape Version 4.4 (R2018a)
Simscape Driveline Version 2.14 (R2018a)
Simscape Electronics Version 2.13 (R2018a)
Simscape Fluids Version 2.4 (R2018a)
Simscape Multibody Version 5.2 (R2018a)
Simscape Power Systems Version 6.9 (R2018a)
Simulink 3D Animation Version 8.0 (R2018a)
Simulink Check Version 4.1 (R2018a)
Simulink Coder Version 8.14 (R2018a)
Simulink Control Design Version 5.1 (R2018a)
Simulink Coverage Version 4.1 (R2018a)
Simulink Design Optimization Version 3.4 (R2018a)
Simulink Desktop Real-Time Version 5.6 (R2018a)
Simulink Real-Time Version 6.8 (R2018a)
Simulink Requirements Version 1.1 (R2018a)
Spreadsheet Link Version 3.3.3 (R2018a)
Stateflow Version 9.1 (R2018a)
Statistics and Machine Learning Toolbox Version 11.3 (R2018a)
Symbolic Math Toolbox Version 8.1 (R2018a)
System Identification Toolbox Version 9.8 (R2018a)
Vehicle Network Toolbox Version 4.0 (R2018a)
Wavelet Toolbox Version 5.0 (R2018a)

pastedImage_1.png

Thank you,

Fernando

0 Kudos

450 Views
constantinrazva
NXP Employee
NXP Employee

Hello fernando.barrios@uwaterloo.ca‌,

Sorry for the late reply - the models work on my end on a fresh install. This makes me think there is either a problem with the path, either a problem if you have MATLAB / Simulink / our toolbox installed on a network drive.

For the first one, can you try and reset the MATLAB path? For that you should go to MATLAB Home tab -> Set Path -> Default -> Save.

Capture.JPG

 

Untitled.png

and then run the mbd_s32k_path script again, so you install the path for the toolbox over a fresh, default MATLAB path. 

 

Note: this will remove additional toolboxes path, so you'll have to add them back later.

For the second one [if you have it installed on a network drive], can you try and install everything locally and see if it fixes the problem? We had a few users that had this issue and it was fixed by installing locally.

 

Kind regards,

Razvan.

0 Kudos