MPC5744p RevE communication problem

cancel
Showing results for 
Search instead for 
Did you mean: 

MPC5744p RevE communication problem

233 Views
Contributor II

Hi NXP team and fellow members,

 

I have recently ordered MPC5744P DevKit and received the Rev E DevKit. I tried to compile and download the code from Simulink model-based toolbox example by following the quick start guide which came with the MBD toolbox. I have successfully downloaded  the code from simulink model-based toolbox example to the devkit. But a few days later , I kept getting the message prompt showing that there is a CCP communication error even though I have flash the bootloader via S32 as mentioned in the quick start guide.I have tired another PC,but the problem still can be solved.

Could you kindly guide me to solve this problem?

Thanks.

2 Replies

4 Views
NXP Employee
NXP Employee

Hello m15871781742@163.com‌,

The MPC5744P RevE uses another serial connected to OpenSDA than the older MPC5744P devkit. For that, another rbf must be flashed. We have a topic [1] on which we discussed that, together with another problem. If you have already flashed the rbf from [1], please change the computer usb port on which the board is connected. For other users this worked.

Also, which MBDT version are you using?

[1]https://community.nxp.com/thread/509064?commentID=1211928&et=notification.mention#comment-1211928

Hope this helps,

Marius

0 Kudos

4 Views
Contributor III

Unfortunately, I have the same problem. I couldn't find any example using the MPC5744p RevE and Matlab 2018b

0 Kudos