MBD S32K demo program download

cancel
Showing results for 
Search instead for 
Did you mean: 

MBD S32K demo program download

226 Views
Contributor II

1.png

2.png3.png

 

First, OpenSDA Drive was not recognized after I installed the S32K Toolbox;

Then, I set "Custon OpenSDA Drive Name" to" H:EVB-S32K144";

4.png

And then download the program, and it's stuck here;

5.png

I think the program didn't download into S32K144EVB, but I don't know how to solve it;

Finally, I tried serial downloading again, but I still failed.

8.png

 

Please help me!!

0 Kudos
9 Replies

218 Views
NXP Employee
NXP Employee

Hello @orange_ ,

If you press the refresh button, the driver E should be displayed next to the Custom option, like in the following image. But make sure you have the OpenSDA selected because it looks like the model tries to download over the Serial option.

mariuslucianand_0-1605885199182.png

If this still does not work, select Custom option but type only the letter E in the Drive Name.

mariuslucianand_1-1605885268609.png

Hope this helps,

Marius

 

 

0 Kudos

199 Views
Contributor II

Hello Marius,

First, I have selected OpenSDA, and then I did the following:


1. Click "Refresh", but "H: EVB-S32K144" is not recognized;

1.png

2.png


2. "H" or "H:EVB-S32K144" were set in "Custom OpenSDA Drive Name", but the results faile. The program is always loaded here.

3.png

Please help me,

Orange_

0 Kudos

191 Views
NXP Employee
NXP Employee

Hello @orange_ ,

Does your user has enough privileges to access that drive?

When the process completes, then go inside the generate folder, and copy the .mot generated file in the local disk H.

Hope this helps,

Marius

0 Kudos

155 Views
Contributor II

Hello Marius,

Could you please specify how to set the drive access?

I don't know exactly how to set the access rights of "H: EVB-S32K144", and I keep stopping in this interface and can't proceed to the next step.

5.png

 

I can see "gpio. s32k1414. mot" in drive "H: EVB-S32k144" directory, but the hardware has no response.

6.png

Please help me!!

Orange_

0 Kudos

123 Views
NXP Employee
NXP Employee

Hello @orange_ ,

It looks like the .mot file gets on the OpenSDA on the board, but something is not right with the board.

Please open the LASTSAT.TXT and check its content.

Can you pleae check the jumpers settings on the EVB board?

mariuslucianand_0-1605975635927.png

Regards,

Marius

0 Kudos

91 Views
Contributor II

Hello @mariuslucianand ,

Since I can use OenpSDA to download programs for "S32K144EVB" in the S32DS environment, I tried to replace the "GCC-6.3-Arm32-eABI" folder in the MATLAB directory with the "GCC-6.3-Arm32-eABI" folder in the S32DS directory. As a result, I was able to download programs for "S32K144EVB".

Of course, I also need to customize "OpenSDA Drive Name" to "H".

I sincerely thank you for your guidance and advice on this issue.

Although I can download the program successfully now, I still don't understand why this is successful, if you can tell me the reason, I would be very grateful.

Orange_

0 Kudos

65 Views
NXP Employee
NXP Employee

Hello Orange,

Well, as I said before, looks like the program (gpio_s32k144.mot) is successfully copied on the board. So there might be an issue either with the board or with the OpenSDA.

I don't understand what you have done by copying the GCC-6.3-Arm32-eABI" folder...

Also, I don't understand your status. Is the program running on the board, or not?

On the S32K144 there is an LED, D2, next to the OpenSDA board. This led is a status indicator. The following document explains the status codes. https://www.nxp.com/docs/en/user-guide/OPENSDAUG.pdf 

So I see two options in your case. 

1. Try to update the OpenSDA firmware (see the previous document explanation)

2. Make sure that your user has enough privileges to access external USB dis. For that, contact your it administrator.

Hope this helps,

Marius

0 Kudos

110 Views
Contributor II

Hello @mariuslucianand,

As you can see in the figure, I have successfully connected "S32K144EVB" to my computer, but "OpenSDA" is not recognized and still not recognized after pressing "Refresh", so I type "H" in "Custom OpenSDA Drive Name";

1.png

This is the result of "build". The program stops at this interface and cannot proceed to the next step;

2.png

The result of opening the LASTSAT.TXT is shown in the figure below;

3.png

Finally, refer to the "Model-based Design Toolbox QSG" and I have set that place J107 jumper on positions 2-3 and place J104 jumper on positions 2-3;

The program always stops at that interface and can't take the next step, and the hardware isn't responding.

I really need your help. Please help me!!

Orange_

0 Kudos

172 Views
Contributor II

Hello Marius,

Thank you for your suggestion.

Could you please explain it in detail?

Orange_

0 Kudos