Fail to use Model-Based Design Toolbox with MPC5744P

cancel
Showing results for 
Search instead for 
Did you mean: 

Fail to use Model-Based Design Toolbox with MPC5744P

106 Views
Contributor II

Hi,

   I,m using the Model-Based Design Toolbox MPC57xx Series, I followed the quick start guide with the uart_hello_world_mpc574xP.mdl example. However, after I click the code generate and build model button in Simulink, and pressed the RESET button, it showed that "Loss communication with CCP MCU. Please cycle power and try again."

   I'm sure that I choose the right COM port and I've successfully flashed some example by S32DS. Also I tried different .rbf files which I found in the community. I heard there are some bugs in S32DS_PA_2.1 with MBDT, shall I try version 2017R1?

   My configuartion is the following:

   S32DS_PA_2.1

   Matlab R2020a

   Model-Based Design Toolbox 3.1.0

   DEVKIT-MPC5744P

S32DS.png

pastedImage_3.png

Best regards!

Kisen

0 Kudos
2 Replies

19 Views
NXP Employee
NXP Employee

Hello 641679783@qq.com‌,

Can you please tell me which revision board are you using?

If you are using the revision E, probably this post might help you https://community.nxp.com/message/1351333?commentID=1351333#comment-1351333 

There serial connected to the OpenSDA differs from one revision to another so the bootloader is different.

Hope this helps,

Marius

0 Kudos

19 Views
Contributor II

Hello mariuslucianandrei

Thanks for your help.

I'm not sure how to identify the revision, it seems like I'm using a REV B board.

pastedImage_1.png

Also, I've already tried the .rbf file before in https://community.nxp.com/message/1351333?commentID=1351333#comment-1351333, and met the same problem.

0 Kudos