DataMemWrite/DataMemRead access

cancel
Showing results for 
Search instead for 
Did you mean: 

DataMemWrite/DataMemRead access

86 Views
Contributor III

Hello,

I have a system in which I added the MemWrite and MemRead blocks. When I try to put the memory address for the eDMA to look for them, it only sends back the first digit of the ID I sent initially, for example, if I send an ID of 756, it sends me back only 7. Same with other IDs.  

This is my current block configuration (I've already tried changing the transfer size and the number of bytes on each transfer):

juliana_rojas30_0-1600769571634.png

I need to know how to access it in order for it to send me back the entire ID that I am sending to it. Does anybody know what to do?

Kind regards.

0 Kudos
1 Reply

66 Views
Contributor III

Hello @constantinrazva ,

Welcome back!

Can you please comment something on this thread? I am stuck here. To sumarize, my main issue is: I need to know how to access the CAN peripherals in my design, specifically, which are the registers I am supposed to use in the Source and Destination List (in order to implement DMA). I have tried with several of the ones available among the options, but no success. 

juliana_rojas30_1-1601026216618.png

My final objective is to copy from memory to peripheral, but for now, as an initial setup, I tried to copy the data from memory to memory, in order to just test the DMA behavior, but I am having issues with this as well because of the addresses.

I have tried several things, but the closest I've gotten to succes was using the addresses 0x2000000 with "neighboor" offsets (0x0001,0x0002,etc), but the result was that I only got the first number of the initial ID I was trying to get back. So, I guess this is not right either.

Do you have any suggestion or explanation for this issue?  

Kind regards,

Juliana

0 Kudos