COM Port always sets itself back to COM Port 1 after update.

cancel
Showing results for 
Search instead for 
Did you mean: 

COM Port always sets itself back to COM Port 1 after update.

331 Views
Contributor II

I am quite new in using the NXP Model Based Design Toolbox so I have been following the tutorials on MPC574xP - Videos to get started, specifically the ADC_read project.

I have applied the slsfnagctlr hot fix found on the thread https://community.nxp.com/thread/451804 so the code generation step works, however, I am experiencing a strange bug regarding the COM port selection for the DEVKIT. On the device manager, the DEVKIT is given COM6 but when I try to update this in the MBD_MPC574xP_Config_Information block, the COM Port value jumps back to COM1 whenever I press the Apply or OK button or just wait a few seconds. This behavior is difficult to capture in a screenshot, which should at least provide some context.

ADC_read_params.png

0 Kudos
3 Replies

66 Views
NXP Employee
NXP Employee

Hi chuluezhong‌,

What is the MATLAB version you are using ?

Thank you!

Daniel

0 Kudos

66 Views
Contributor II

R2017b

0 Kudos

66 Views
NXP Employee
NXP Employee

Hello, 

I tried different scenarios but i could not replicate the issue on my side. In the code there is nothing particular with this edit box - it is just a simple value that is only read from the UI, while saving of default values are handled by Matlab itself.

Do you experience such behaviors with other blocks settings ?

Best regards,
Daniel

0 Kudos