After Download the code My design 5744P board cannot work

cancel
Showing results for 
Search instead for 
Did you mean: 

After Download the code My design 5744P board cannot work

255 Views
Contributor III

Hi, everyone.

 I have done the GPIO demo model on the Devkit-MPC5744P board , and when I set PA4=1,PA3=0,PA2=0 by hardware ,I can use the UART1 download the code by  USB2Serial,and the I/O work well.

But when I used my own design 5744P board,when I set PA4=1,PA3=0,PA2=0, I bulid the same GPIO demo,it cannot download code by the same USB2Seria,when I set PA4=0,PA3=0,PA2=0, I bulid the same GPIO model,it can download code,but the I/O without output as I wanted .Can you please tell me what is the issue here.

I do appreciate it if you could help. 

0 Kudos
4 Replies

80 Views
NXP Employee
NXP Employee

Hello 13226508@qq.com‌,

The toolbox generates the code based on the EvalBoard schematics which has connected an external 40MHz crystal oscilator. I don't know the settings on the clock in the bootloader. 

So, you can't use at all any of the GPIOs or only the PA2/3/4?

Marius

0 Kudos

80 Views
NXP Employee
NXP Employee

Hello 13226508@qq.com‌,

The pins you are referring at are responsible for the boot configuration. And, as far as I understand, you are now forced to keep those pins on 1,0,0 states on the entire application. You can find more about the states in the Reference Manual, chapter Chapter 55 Boot Assist Module (BAM).

Now, to prevent that, on the Evaluation board there is the U26 which enables a custom state on the each pin only when the processor is in the reset state. After the processor boots up this set the pin in Z state allowing the processor to use that pin as a regular GPIO.

pastedImage_1.png

Hope this helps you, 

Marius

0 Kudos

80 Views
Contributor III

Hello marius,

      My custom board cannot work still.I want to konw if I have already programmed the RBF file into the flash memory, the  external crystal oscillator could  work?(I found my  external crystal work at 40M.)When I set PA4=Z,PA3=0,PA2=0, I could program form simulink with GPIO model( the model could work correctly on the 5744 demo board),but  I/O without output .Can you help me solve it?

I will highly appreciate!IMG_20190420_152625.jpgIMG_20190420_150823.jpg

0 Kudos

80 Views
Contributor III

Hello,

     I have used  74LVC125 as the same way, and what the Z satate?

0 Kudos