i trying to boot using kernel 4.9 and stuck at . Waiting for root device /dev/mmcblk0p2...

cancel
Showing results for 
Search instead for 
Did you mean: 

i trying to boot using kernel 4.9 and stuck at . Waiting for root device /dev/mmcblk0p2...

652 Views
abhay_kumar
Contributor I

i am using board NXP S32V234EVB.

it is able to boot with 4.1 and i am trying to port it to 4.9. and facing this issue.


Forcing PCIe to Gen1 operation
phy link never came up
DEBUG_R0: 0x004efe00, DEBUG_R1: 0x08200000
In: serial
Out: serial
Err: serial
The security module (CSE3) is disabled.
Net: CPU Net Initialization Failed
No ethernet found.
Hit any key to stop autoboot: 0
switch to partitions #0, OK
mmc0 is current device
reading Image
6641672 bytes read in 678 ms (9.3 MiB/s)
Booting from mmc ...
reading s32v234-evb.dtb
11359 bytes read in 19 ms (583 KiB/s)
## Flattened Device Tree blob at 82000000
Booting using the fdt blob at 0x82000000
reserving fdt memory region: addr=c0000000 size=10000
Loading Device Tree to 000000009fffa000, end 000000009ffffc5e ... OK

[ 1.086140] sit: IPv6, IPv4 and MPLS over IPv4 tunneling driver
[ 1.094777] NET: Registered protocol family 17
[ 1.100730] can: controller area network core (rev 20120528 abi 9)
[ 1.109056] NET: Registered protocol family 29
[ 1.114986] can: raw protocol (rev 20120528)
[ 1.120686] can: broadcast manager protocol (rev 20161123 t)
[ 1.128240] can: netlink gateway (rev 20130117) max_hops=1
[ 1.135608] Key type dns_resolver registered
[ 1.145827] Waiting for root device /dev/mmcblk0p2...

it got stuck after this?

if you can help me out. it would be great for me.

thanks

Labels (1)
Tags (2)
0 Kudos
3 Replies

195 Views
nxf40536
NXP Employee
NXP Employee

Hi abhay kumar,

This might be caused by the memory card reader driver. If you have an external card reader you might not encounter the problem. Nevertheless, we were able to reproduce the problem on one of our computers and we do have something that might be able to fix your problem.

Can you please go to the create folder in the add-on folder (e.g. Add-Ons\Toolboxes\NXP_Vision_Toolbox_for_S32V234\code\internals\target\create\ - you can run 'nxpvt_tbx_root' to find out the add-on installation folder and copy the attached .p and .exe in the attached archive and then try running the create command again ?

nxpvt_create_target('%% PATH_TO_IMAGE_FOLDER%%\S32V234-EVB_29288_image.gz', '[Drive Letter]:')

Hope this helps,

Vlad Dascau

0 Kudos

195 Views
nxf40536
NXP Employee
NXP Employee

Hello,

Since you are saying you are trying to update from 4.1 to 4.9 can you, please, give us a bit more detail about that ? Can you give us a full set of steps you are taking in order to do that ?  Are you using our nxpvt_create_target script ? Were you able to successfully load an image with the 4.1 kernel using the script ? 

 

Thank you,

Vlad Dascau

0 Kudos

195 Views
dumitru-daniel_
NXP Employee
NXP Employee

Hi abhay.kumar@lnttechservices.com‌,

Are you using this board ?

pastedImage_1.png

and these boot settings ?

pastedImage_2.png

Best regards,

Daniel

0 Kudos