Can not connect to freemaster with DEVKIT-5744P

cancel
Showing results for 
Search instead for 
Did you mean: 

Can not connect to freemaster with DEVKIT-5744P

593 Views
fortunely
Contributor III

According to the training GPIO Programming|NXP , I can not connect to freemaster with DEVKIT-5744P. It shows error code: 0x80000101, using the attachment demo, just like figure1. I have tried serval times, but it remains the same result.

1) Success: build and download program;

2) Failure: connect to freemaster;

Anyone can help to see it? Thanks.

  • Test Condition

EVB : DEVKIT-5744P

Matlab: 2016b x 64bit

OS: Win10 professional x 64bit

Figure1 Connect Freemaster Error 

MBDT_ERROR_CONNECTFREEMASTER1.png

The following is my freemaster configurations:

1) Freemaster2.0->Project->Options

MBDT_ERROR_CONNECTFREEMASTER2.png

2) MAP settings

MBDT_ERROR_CONNECTFREEMASTER_MAPSETTING.png

3) PC device management

MBDT_ERROR_CONNECTFREEMASTER3.png

Labels (2)
0 Kudos
4 Replies

193 Views
constantinrazva
NXP Employee
NXP Employee

Hello fortunely‌,

You are doing the right steps for building and connecting to the board via FreeMaster; I can not seem to be able to replicate the failure. As you can see here

pastedImage_1.jpg

building your model and connecting with FreeMaster works. Maybe there is a hardware problem - can you make a simple application in which you send a message on the serial interface and see if you receive it? 

Hope this helps!

Razvan.

0 Kudos

193 Views
fortunely
Contributor III

Hi razvanchivu,

My evb DEVKIT-5744P's UART module(OpenSDA) works normally. I can send and receive UART message, using openSDA.

I use demo linflexd_uart_echo_mpc5744p(Beta SDK v0.9.0) in IDE S32DS for Power v2017.R1.

MBDT_UART_Result.png

My UART configuration

1) UART config: Device = LINFlexD_1, Baud rate=115200, Transfer type=Interrupts

MBDT_UART_Config.png

2) UART PIN config: Use LINFlexD_1, Rx=PD[12], Tx=PD[9]

MBDT_UART_PINConfig.png

3) JUMPER config

MBDT_DEVKIT-5744P_JUMPER.jpg

0 Kudos

193 Views
constantinrazva
NXP Employee
NXP Employee

Hello fortunely‌,

I am not sure of the position of J13 in your configuration - besides that, you have the same configuration as I do. Can you put the J13 jumper to 2-3 (selecting "USB/UART connector") ?

Capture.JPG

Please let me know if this works.

Razvan.

0 Kudos

193 Views
fortunely
Contributor III

Hi razvanchivu,

Thank you for your help.

Now I know how to connect to freemaster now, though I do not know the special reason. 

That is, the error hint will still happen when I firstly connect to freemaster with DEVKIT-5744P, after reset. But it all wiil be OK if I click "close port" button and then click "STOP" button in the freemaster toolbar. 

Surely, the power jumper J13 is right(using default 2-3: USB powered 5V) of My DEVKIT-5744P, otherwise, there will not be 3 lightening green leds(using 1-2: just  1 lightening green led).

Figure1 How to Connect to Freemaster in Term of Right Configuration 

MBDT_CONNECTFREEMASATER_OPERATION.png

Figure2 My EVB's J13 settings

MBDT_DEVKIT-5744P_J13.jpg