what this error means "Failed to initialise Ethernet device, error = A414"

cancel
Showing results for 
Search instead for 
Did you mean: 

what this error means "Failed to initialise Ethernet device, error = A414"

Jump to solution
299 Views
Swapnil_Enable
Contributor III

i am developing product using MK60n512 with MQX and it RTSC stack. The development work is going fine till yesterday evening when i left my office. when i complied the code for first time today morning a strange error "Failed to initialise Ethernet device, error = A414" occurred on the terminal. this error should come after error = RTCS_create();if it is not created. when i search for the error code in the rtcs.h file i don't see any corresponding error. please giude me how to resolve it.

Labels (1)
0 Kudos
1 Solution
133 Views
butok
NXP Employee
NXP Employee

Hi Swapnil Karte,

This strange error "Failed to initialize Ethernet device, error = A414" corresponds to ENETERR_ALLOC_BUFFERS error => the buffer allocation is Failed in MACNET_initialize()  => you do not have enough of free memory for Ethernet buffers allocation => try to free resources used by your application.

Best regards,

Andrey Butok

View solution in original post

0 Kudos
3 Replies
134 Views
butok
NXP Employee
NXP Employee

Hi Swapnil Karte,

This strange error "Failed to initialize Ethernet device, error = A414" corresponds to ENETERR_ALLOC_BUFFERS error => the buffer allocation is Failed in MACNET_initialize()  => you do not have enough of free memory for Ethernet buffers allocation => try to free resources used by your application.

Best regards,

Andrey Butok

View solution in original post

0 Kudos
133 Views
Swapnil_Enable
Contributor III

Thanks Andrey, strangely this problem solve when i reduced the runtime RTCS configuration to 45. Initially it was set to 100 from 30 when the problem arises. Problem setting: /* runtime RTCS configuration */       _RTCSPCB_init = 100;       _RTCS_msgpool_init = 100;       _RTCS_socket_part_init = 100; but still i am not able to figure it out why this occurred. somewhere i read if i set this value to 0(zero) rtos will set on its own to the requirement. Please help me in setting this values as my requirement is 12 TCP server port with each only one socket, 2 client TCP port with one socket each the application is deamon server-client

0 Kudos
133 Views
butok
NXP Employee
NXP Employee

Hi Swapnil Karte,


Changing of<xxx>_init  is wasting of memory from real beginning, by pre-allocating/reserving memory.

You should change <xxx>_max value (or RTCSCFG_<xxx>_MAX). But be careful - do not set it too high, as your application will stop working in some time, cause of lack of memory. The issue is that a partition allocates memory but does not return it back.

I would start from value 10 (NOT from 100 – only in case you have a lot of external memory).

Best regards,

Andrey Butok

0 Kudos