TWR-K65F180M system for Ethernet communication

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

TWR-K65F180M system for Ethernet communication

Jump to solution
1,968 Views
michaelpribble
Contributor I

I'm having a problem similar to the one discussed in the following thread:

TWR-K60F120M system for Ethernet communication

The main difference is I am using the TWR-K65F180M board instead of the TWR-K60F120M board. In order to test out the ethernet capability, I am trying to run the eth_to_serial example application (found under C:\Freescale\KSDK_1.3.0\middleware\tcpip\rtcs\examples\eth_to_serial). I'm able to successfully build and deploy the application to the development board (deployment using the OpenSDA connector on the TWR-K65F board).

The application starts up as expected. First, the serial console (I'm using PuTTY) on my laptop displays the expected message:

Application listening on following ip addresses:

  IPv4 Address: 172.16.10.2, port:23

Waiting for incoming connection...

Note that I modified the ENET_IPADDR macro to use a different IP address than the original 192.168.1.202 address. I did this in order to keep it separate from my regular network. Anyway, by this point the code has successfully set up the socket and is pended on a call to select(), waiting for a connection request to come in.

At this point, I open up another PuTTY shell, this time a raw connection, and attempt to connect to 172.16.10.2:23. Not only is the connection never accepted, but I can see in the debugger that the call to select() is not even returning. This latter fact suggests to me that I have something physically assembled incorrectly, but I don't know what. So here's what I have:

  • TWR-K65F and TWR-SER board are sandwiched between the two TWR-ELEV boards. Yes, I made sure to match primary and secondary correctly.
  • Mini-USB connection from laptop to OpenSDA port on the TWR-K65F board. I am using this for debug and serial console
  • Ethernet cable connected between TWR-SER board and a USB-to-Ethernet adapter attached to my laptop. I've configured the interface with the adapter with the address 172.16.10.1/24.
  • TWR-K65F jumper settings have not been touched.
  • TWR-SER jumper settings - following modifications:
    • Moved shunt on J2 from 1-2 to 3-4 to select 50 MHz clock
    • Shunted pins 2-3 on J3 to route the 50MHz clock to CLOCKIN0
    • Shunted pins 9-10 on J12 to select RMII mode.

The TWR-SER jumper settings I chose were suggested in Table 4 of the following document: http://cache.freescale.com/files/32bit/doc/ref_manual/TWR-K60N512-UM.pdf

The user guide for my TWR-K65F board (http://cache.nxp.com/files/32bit/doc/user_guide/TWRK65F180MUG.pdf ) doesn't have any suggestions.

If anybody can point out what I'm doing wrong, I'd love to know. Thanks!

0 Kudos
1 Solution
1,612 Views
soledad
NXP Employee
NXP Employee

Hello Michael,

Could you please try using the below Jumper Settings??

TWR-K65F180M

• Jumper J6 on position 1-2.

• Jumpers J1, J8, J10, J13, J14, J20, J24, J30 and J32 closed.

• Jumper J21, J19 all open.

• Jumpers closed on positions J22 (1-2, 3-4), J3 (1-2), J9 (5-6), J16 (1-2) and J27 (2-3).

• TWR-SER - CLK_SEL 3-4

• TWR-SER - CLKIN-SEL 2-3 (processor clock is taken from PHY)

• TWR-SER - ETH-CONFIG J12 9-10 to select RMII communication mode

• Important: Plug both the processor and the serial board (TWR-SER) into the Tower. The processor is using the

external clock from the Ethernet PHY on the serial card.

Please let me know if this helps!!

Have a great day,
Sol

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

View solution in original post

0 Kudos
3 Replies
1,548 Views
jill1
Contributor I

Hello Michael,

I'm trying to run the eth_to_serial application aswell. Every time I run the application I receive some errors that the variables aren't declared. Did you have similar problems and have tips for me how to fix it?

Best regards,

Jill

0 Kudos
1,613 Views
soledad
NXP Employee
NXP Employee

Hello Michael,

Could you please try using the below Jumper Settings??

TWR-K65F180M

• Jumper J6 on position 1-2.

• Jumpers J1, J8, J10, J13, J14, J20, J24, J30 and J32 closed.

• Jumper J21, J19 all open.

• Jumpers closed on positions J22 (1-2, 3-4), J3 (1-2), J9 (5-6), J16 (1-2) and J27 (2-3).

• TWR-SER - CLK_SEL 3-4

• TWR-SER - CLKIN-SEL 2-3 (processor clock is taken from PHY)

• TWR-SER - ETH-CONFIG J12 9-10 to select RMII communication mode

• Important: Plug both the processor and the serial board (TWR-SER) into the Tower. The processor is using the

external clock from the Ethernet PHY on the serial card.

Please let me know if this helps!!

Have a great day,
Sol

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos
1,612 Views
michaelpribble
Contributor I

Sol,

Those are exactly the jumper settings I said I had (the TWR-K65 settings you spell out are the factory settings), but because of your post I figured I'd double check everything. Turns out that on the TWR-SER board, I had mistakenly shunted J3 in the 1-2 position (25 MHz), when I meant to shunt it in the 2-3 position (50 MHz)...so I guess I was just a liar. Correcting that mistake fixed everything. Thanks for your help.

Michael

0 Kudos