TWR K60 HVAC web demo

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

TWR K60 HVAC web demo

Jump to solution
1,527 Views
UniversalTroope
Contributor III

I'm trying to run the HVAC webenabled demo on a TWR K60, using MQX 3.6.2 and IAR embedded workbench. The demo stops with "Waiting for ethernet cable plug in ...".

 

I have connected a cable, and the ethernet port LED's are lit. TWR-SER mode is RMII, 50MHz clock routed out, and TWR-K60 set to use that clock.

 

Any ideas?

Labels (1)
Tags (1)
0 Kudos
1 Solution
804 Views
anthony_huereca
NXP Employee
NXP Employee

Try putting the board in MII mode. The MCF52259 BSP is expecting that, not RMII. It would be the original jumper locations on the TWR-SER, which you can find in the TWR-SER user manual: http://cache.freescale.com/files/microcontrollers/doc/user_guide/TWRSERUM.pdf

View solution in original post

0 Kudos
4 Replies
804 Views
UniversalTroope
Contributor III

It seems this doesn't work:

 

ipcfg_get_link_active(IPCFG_default_enet_device)

 

If I disable this check, the demo works fine. Any tips on how to get the cable check working?

0 Kudos
804 Views
PetrM
Senior Contributor I

Please make sure you have the switches on serial and processor boards set according to getting started manual.

It works for me.

 

PetrM

 

0 Kudos
804 Views
UniversalTroope
Contributor III

Sorry, it was the security demo that stops on that cable check, but the hvac demo also doesn't correctly detect the link state.

0 Kudos
805 Views
anthony_huereca
NXP Employee
NXP Employee

Try putting the board in MII mode. The MCF52259 BSP is expecting that, not RMII. It would be the original jumper locations on the TWR-SER, which you can find in the TWR-SER user manual: http://cache.freescale.com/files/microcontrollers/doc/user_guide/TWRSERUM.pdf

0 Kudos