RTCS viewer (TAD) for Keil is not showing

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

RTCS viewer (TAD) for Keil is not showing

3,759 Views
panpwr
Contributor IV

Recently I've installed Keil uVision ver 4.60, (ARM-MDK), for use with my MQX 4.0.

When I was using uVision 4.54, I could have used the MQX & RTCS viewers (TAD) debug menus: "Debug->OS Support->RTCS (or) MQX ->...".

However, once I've installed uVision 4.60, I can't see the "RTCS" menu, only "MQX" menu. I've re-installed Freescale's TAD extension for Keil which came with MQX 4.0, however - it didn't work as well.

I assume that I haven't compiled something correctly in the MQX project (which wasn't by default in the new uVision default)

How do I get the RTCS viewer ability back?

Thanks,

Lior.

8 Replies

3,093 Views
c0170
Senior Contributor III

Hello panpwr,

have you solved your issue? I have currently installed only 4.53 version, but in case your problem still persists, I'll get newer version.

Regards,

MartinK

3,093 Views
panpwr
Contributor IV

Hello Kojto,

The problem still persists - I can't see the "RTCS" option.

Here is the answer I've received from ARM:

The menu items under "Debug->OS Support" are defined by the RTOS-Viewer dll. So the authors

of the dll need to comment this. For reference, see our application note:

http://www.keil.com/appnotes/docs/apnt_204.asp and in there the section: "Create an RTOS-Viewer Plug-in->General Message Handling->Attach a Menu".

What RTOS-Viewer dll is in use, can be seen in the C:\KEIL\TOOLS.ini file. Look there for the

"RTOS(x)="-line referring to the MQX stuff.

I would very appreciate if you could assist with this issue.

Thanks,
Lior.

3,093 Views
panpwr
Contributor IV

Kojto,


Any news with this issue?


Thanks,

Lior.

3,093 Views
c0170
Senior Contributor III

I installed KEIL and run one RTCS example but MQX TAD did not show in options. Something with my configuration, I believe. I have to check it again :smileywink: Sorry for delay, I'll keep you posted or at least somebody else will :smileywink:

Update:

Mine problem was with TOOLS.in in KEIL root directory, MQX was as RTOS0 which was not shown in KEIL project options. I renamed it to RTOS2 and it's there finally.

RTOS0=Dummy.DLL("Dummy")

RTOS1=VARTXARM.DLL ("RTX Kernel")

RTOS2=MQXViewer.dll ("Freescale MQX")


This might be not your case, but RTCS should be shown there if projects contains RTCS. I tested shell application, I can confirm TAD (MQX, RTCS) is functional.


Regards,

MartinK

3,093 Views
panpwr
Contributor IV

Hello Kojto,

Thank you for the reply.

I've checked, and I do have:

RTOS0=MQXViewer.dll ("Freescale MQX") under [ARM].

and also:

RTOS0=Dummy.DLL("Dummy")

RTOS1=VARTXARM.DLL ("RTX Kernel")

RTOS2=MQXViewer.dll ("Freescale MQX") under [ARMADS],

But still - I have only "MQX" debug menu, but not "RTCS". Could it have to do something with the new library structure in MQX 4.0? Should the project include a specific library name, in order to enable this feature?

Thanks,

Lior.

3,093 Views
c0170
Senior Contributor III

Hello panpwr,

Any success there?

It displays both MQX and RTCS. I tested it on K60 SHELL example in RTCS (Keil 4.6.0). If you include RTCS lib, it should appear there.

Regards,

MartinK

3,093 Views
panpwr
Contributor IV

Hello Kojto,

I've followed your advice, and opened the shell example - it seems to work there. And than I've started to look for the differences:

I've noticed that there is a "debug rtcs.lib" and a "release rtcs.lib", while in my project there is only one "rtcs.lib" (it was the release library).

I've added the "rtcs.lib" from the debug directory to my project - and now I can see the RTCS debug menu! :smileyhappy:

I've probably missed that because both files are displayed as "rtcs.lib" (while in the previous uvision version, the files were named differently (rtcs_twrk60d100m_d.lib & rtcs_twrk60d100m.lib)).

So now that it work, only a small question - do you happen to know how to rename the display name of the library in the project window (just the displayed names, since the both debug & release file names are "rtcs.lib"). A plain "right click-> Rename" is missing...

An update:

Please see the following screenshot, in order to understand my question better:

You could see here that the same file name (though from different directory) has different display name. However, uVision4 doesn't let you to determine the Display name, so how could whoever wrote this example do that?

Seperate_Release_And_Debug_BSP_same_workspace.jpg

Thanks!

3,093 Views
panpwr
Contributor IV

OK, I've received a response from Keil team:

"This seems to be added manually directly in the .uvproj file since uVision IDE did not allow this so far".

"FileName" is used to display the file in the project tree and if you try to add a file with the same name in the same group uVision will block this. For all other actions, like adding a library file to the linker command line the "FilePath" is used."

Anyway, even after adding this manually, and even though I can now see both debug and release versions of "rtcs.lib" in the project explorer - the RTCS doesn't work for me (now I can actually see the RTCS menu, but every option I choose displays "RTCS Data is not currently valid").

How can I finally activate properly the RTCS debugging in uVision4 ?!?!?

Thanks,

Lior.